Home > Network Address Translation NAT Tutorial

Network Address Translation NAT Tutorial

May 22nd, 2011 Go to comments

To go to the Internet we need to get an public IP address and it is unique all over the world. If each host in the world required a unique public IP address, we would have run out of IP address years ago. But by using Network Address Translation (NAT) we can save tons of IP addresses for later uses. We can understand NAT like this:

“NAT allows a host that does not have a valid registered IP address to communicate with other hosts through the Internet”

For example your computer is assigned a private IP address of 10.0.0.9 and of course this address can not be routed on the internet but you can still access the internet. This is because your router (or modem) translates this address into a public IP address, 123.12.23.1 for example, before routing your data into the internet.

NAT_Basic.jpg

Of course when your router receives a reply packet destined for 123.12.23.1 it will convert back to your private IP 10.0.0.9 before sending that packet to you.

Maybe you will ask “hey, I don’t see any difference of using NAT to save tons of IP addresses because you still need a public IP address for each host to access the Internet and it doesn’t save you anything, why you need to use NAT?”

Ok, you are right :), in the above example we don’t see its usefulness but you now understand the fundamental of NAT!

Let’s take another example!

Suppose your company has 500 employees but your Internet Service Provider (ISP) only gives you 50 public IP addresses. It means that you can only allow 50 hosts to access the internet at the same time. Here NAT comes to save your life!

One thing you should notice that in real life, not all of your employees uses internet at the same time. Say, maybe 50 of them use internet to read newspaper at the morning; 50 others use internet at noon for checking mail… By using NAT you can dynamically assign these 50 public IP addresses to those who really need them at that time. This is called dynamic NAT.

But the above NAT solution does not solve our problem completely because in some days there can be more than 50 people surfing web at the morning. In this case, only the first 50 people can access internet, others must wait to their turns.

Another problem is, in fact, your ISP only gives you much lesser IP addresses than the number 50 because each public IP is very precious now.

To solve the two problems above, another feature of NAT can be used: NAT Overload or sometimes called Port Address Translation (PAT)

PAT permits multiple devices on a local area network (LAN) to be mapped to a single public IP address with different port numbers. Therefore, it’s also known as port address translation (PAT). When using PAT, the router maintains unique source port numbers on the inside global IP address to distinguish between translations. In the below example, each host is assigned to the same public IP address 123.1.1.1 1 but with different port numbers (from 1000 to 1002).

PAT_Basic.jpg

Note: Cisco uses the term inside local for the private IP addresses and inside global for the public IP addresses replaced by the router.

The outside host IP address can also be changed with NAT. The outside global address represents the outside host with a public IP address that can be used for routing in the public Internet.

The last term, outside local address, is a private address of an external device as it is referred to by devices on its local network. You can understand outside local address as the inside local address of the external device which lies at the other end of the Internet.

Maybe you will ask how many ports can we use for each IP? Well, because the port number field has 16 bits, PAT can support about 216 ports, which is more than 64,000 connections using one public IP address.

Now you has learned all the most useful features of NAT but we should summary all features of NAT:

There are two types of NAT translation: dynamic and static.

Static NAT: Designed to allow one-to-one mapping between local and global addresses. This flavor requires you to have one real Internet IP address for every host on your network.

Dynamic NAT: Designed to map an unregistered IP address to a registered IP address from a pool of registered IP addresses. You don’t have to statically configure your router to map an inside to an outside address as in static NAT, but you do have to have enough real IP addresses for everyone who wants to send packets through the Internet. With dynamic NAT, you can configure the NAT router with more IP addresses in the inside local address list than in the inside global address pool. When being defined in the inside global address pool, the router allocates registered public IP addresses from the pool until all are allocated. If all the public IP addresses are already allocated, the router discards the packet that requires a public IP address.

PAT (NAT Overloading): is also a kind of dynamic NAT that maps multiple private IP addresses to a single public IP address (many-to-one) by using different ports. Static NAT and Dynamic NAT both require a one-to-one mapping from the inside local to the inside global address. By using PAT, you can have thousands of users connect to the Internet using only one real global IP address. PAT is the technology that helps us not run out of public IP address on the Internet. This is the most popular type of NAT.

Besides NAT gives you the option to advertise only a single address for your entire network to the outside world. Doing this effectively hides the internal network from the public world really well, giving you some additional security for your network.

NAT terms:

* Inside local address – The IP address assigned to a host on the inside network. The address is usually not an IP address assigned by the Internet Network Information Center (InterNIC) or service provider. This address is likely to be an RFC 1918 private address.
* Inside global address – A legitimate IP address assigned by the InterNIC or service provider that represents one or more inside local IP addresses to the outside world.
* Outside local address – The IP address of an outside host as it is known to the hosts on the inside network.
* Outside global address – The IP address assigned to a host on the outside network. The owner of the host assigns this address.

NAT_terms_explained.jpg

To learn how to configure NAT please read my Configure NAT GNS3 Lab tutorial

Comments (130) Comments
Comment pages
1 2 3 511
  1. jojo
    July 24th, 2013

    if 9tut was a girl she definitely will be my wife
    a small advice if your studying for ccna lab sims only study from 9tut
    any questions –mohdjalal0077@gmail.com

  2. samir
    December 22nd, 2013

    !###################################################
    !# Free CCNA Workbook Lab 11-2 R3 Initial Config #
    !###################################################
    !
    enable
    configure terminal
    !
    hostname R3
    no ip domain-lookup
    !
    interface Loopback0
    description ### SIMULATED INTERNET HOST ###
    ip address 4.2.2.2 255.255.255.255
    !
    interface Serial0/0
    description ### PHYSICAL FRAME RELAY INTERFACE ###
    encapsulation frame-relay
    no frame-relay inverse-arp
    exit
    !
    interface Serial0/0.322 point-to-point
    description ### FRAME RELAY LINK TO R2 ###
    ip address 171.18.24.2 255.255.255.224
    frame-relay interface-dlci 322
    exit
    !
    interface Serial0/0
    no shut
    exit
    !
    line con 0
    logging sync
    no exec-timeout
    !
    end

  3. samir
    December 22nd, 2013

    R1#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#interface loopback0
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
    R1(config-if)#ip add 10.55.0.1 255.255.255.0
    R1(config-if)#interface loopback1
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up
    R1(config-if)#ip add 10.55.1.1 255.255.255.0
    R1(config-if)#interface loopback2
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback2, changed state to up
    R1(config-if)#ip add 10.55.2.1 255.255.255.0
    R1(config-if)#interface loopback3
    %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback3, changed state to up
    R1(config-if)#ip add 10.55.3.1 255.255.255.0
    R1(config-if)#exit
    R1(config)#router eigrp 10
    R1(config-router)#network 10.55.0.0 0.0.3.255
    R1(config-router)#end
    R1#

  4. samir
    December 22nd, 2013

    thanks

  5. ashok gaikwad
    January 16th, 2014

    nice…….

  6. Anonymous
    January 17th, 2014

    very clear and easy to understand, thx a lot~

  7. RK
    January 22nd, 2014

    Excellent explanation covering all features/problems. Keep it Up :)

  8. vigneshwaran
    January 23rd, 2014

    thanx its very useful to me and my friednz..:)

  9. HAMMAD HASSAN
    February 23rd, 2014

    v v informative…thanks

  10. Adnan W.
    February 27th, 2014

    Hey 9tut buddies!
    Had anyone taken CCna exam?
    Please let me know what sim questions you got?

  11. Shaon
    April 13th, 2014

    send me latest dump. I will sit for the exam in this week

  12. rs
    May 28th, 2014

    great explanation but the inside/outside local/global diagram needs to be fixed.. thanks

  13. sacasc
    May 29th, 2014

    bitches

  14. Anonymous
    June 18th, 2014

    really clear the natting concept

  15. Mohd Ashfaq
    June 18th, 2014

    very basic is to understand the nat for bigners amazing

  16. Tahir
    August 11th, 2014

    Excellent Explanation……………………

  17. Anonymous
    September 10th, 2014

    wao i realy luv dis am preparin 4 d exam pls any update email: hazzyken@gmail.com

  18. Irvan
    December 15th, 2014

    Thanks

  19. Don79
    January 5th, 2015

    Very Clear and Easy to understand..thanks guys..!!

  20. luj
    January 14th, 2015

    thanks a lot guys, may god bless you!! :-)

  21. IT Auditor
    January 15th, 2015

    I forgot to say Thank you 9tut for all the help that you’ve given to all aspiring CCNA exam takers. 3 years ago I was one of them. Now I’m on my way to take the CCNA Security. I hope the best for all CCNA Exam takers!

  22. xeoboy
    January 22nd, 2015

    thanks IT auditor

  23. gustav
    February 12th, 2015

    pls need latest dump gustavegbe@yahoo.com

  24. Amit Kumar Pandey
    March 1st, 2015

    9 tuts is the Greatest of all the blogs and tutorials found over the internet.You have made our CCNA Study so ..sooo easier .I am so happy and tension free now. Thanks all the members of 9 tuts.

  25. Anonymous
    March 18th, 2015

    Nice stuff mane keep the nice work up!

  26. Ezra Mosomi Epumbi
    March 18th, 2015

    NIce Stuff

  27. mohamed
    March 29th, 2015

    very useful and can clearly understand

  28. SHAMZZ
    May 6th, 2015

    VERY NICE EXPLNTIN,,,,,THANKUU

  29. cherymae
    May 10th, 2015

    please need latest dump…..
    xhe2xisme@gmail.com

  30. Anonymous
    May 27th, 2015

    Understood

Comment pages
1 2 3 511
Add a Comment