Home > CCNA EIGRP LAB Question

CCNA EIGRP LAB Question

January 25th, 2014 Go to comments

Question

After adding R3 router, no routing updates are being exchanged between R3 and the new location. All other inter connectivity and Internet access for the existing locations of the company are working properly.

The task is to identify the fault(s) and correct the router configuration to provide full connectivity between the routers.

Access to the router CLI can be gained by clicking on the appropriate host. All passwords on all routers are cisco.

IP addresses are listed in the chart below.

ccna_eigrp_sim

R1
Fa0/0: 192.168.77.33
S1/0: 198.0.18.6
S0/1: 192.168.60.25
S0/0: 192.168.36.13
R2
Fa0/0: 192.168.60.97
Fa0/1: 192.168.60.113
S0/0: 192.168.36.14
R3
Fa0/0: 192.168.77.34
Fa0/1: 192.168.60.65
Fa1/0: 192.168.60.81
R4
Fa0/0: 192.168.60.129
Fa0/1: 192.168.60.145
S0/1: 192.168.60.26

Answer and explanation

(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://www.9tut.com/eigrp-routing-protocol-tutorial. Note: You can download this sim to practice here: http://www.9tut.com/download/9tut.com_CCNA_EIGRP_sim_question.zip)

We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of R3 router, enter the show running-config command

ccna_eigrp_sim_show_run

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)

To solve this problem, we simply re-configure router R3 with the following commands:

R3>enable (you have to enter cisco as its password here)

R3#configure terminal

R3(config)#no router eigrp 22

R3(config)#router eigrp 212

R3(config-router)#network 192.168.60.0

R3(config-router)#network 192.168.77.0

R3(config-router)#no auto-summary

R3(config-router)#end

R3#copy running-config startup-config

Check R1 router with the show running-config command:

ccna_eigrp_sim_show_run_2

Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize R3 router

R1>enable (you have to enter cisco as its password here)

R1#configure terminal

R1(config)#router eigrp 212

R1(config-router)#network 192.168.77.0

R1(config-router)#end

R1#copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router R3 to other routers!

Modifications:

Maybe in this EIGRP Sim you will see the “passive-interface …” command somewhere in R1 configuration. If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this:

R1:

!
router eigrp 212
passive-interface s1/0
!

then we just leave it. Don’t use the “no passive-interface s1/0″ on R1 because the link between R1 & ISP doesn’t need EIGRP to run on it. A static route from R1 to ISP & “ip default-network” command in R1 are correct so that all the routers (R1, R2, R3, R4) can access the Internet.

(Note: The “ip default-network” command in R1 will advertise the static route of R1 (to go to the Internet) to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines in R1 configuration:

!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!

If you want to learn more about “ip default-network” command please read: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

I read recent comments and realized that you will see the “passive-interface” in the link between R1 & ISP router so just leave it.

Note: Also some readers confuse about if we should use the wildcard masks on the “network” statements under EIGRP process or not. For example should we use:

router eigrp 212
network 192.168.77.0 0.0.0.3

The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not make the routes conflicting. The “network …” command in EIGRP (and OSPF, RIP) does not means “advertise this network” but means “If I has interface(s) belongs to this network please turn on EIGRP on that interface. Therefore when you don’t use wildcard mask EIGRP will turn on EIGRP on all interfaces that belongs to the network you specify in the “network …” command.

You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same major networks but you don’t want to run EIGRP on all of them. For example if your router has 2 interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP on the first interface, you can type “network 192.168.30.0 0.0.0.15″ under EIGRP process.

Other lab-sims on this site:

CCNA Access List Sim

CCNA NAT SIM Question 1

CCNA NAT SIM Question 2

CCNA Frame Relay Sim

CCNA Configuration SIM Question (RIPv2 SIM)

CCNA VTP SIM

CCNA Drag and Drop SIM

CCNA Implementation SIM

 

Comments
Comment pages
1 15 16 17 18 19 77 29
  1. LeRo
    February 13th, 2012

    I have just passed with 960.
    Carefully with network at R1 ” no network 192.168.29.0″ and add “network 192.168.22.0″
    Good luck!

  2. czona
    February 13th, 2012

    Hi 9tut!

    I have a question. In your explanation you wrote:
    “ip default-network 198.0.18.0
    ip route 0.0.0.0 0.0.0.0 198.0.18.5″
    but i don´t understand from where are you the IP address of next hop: 198.0.18.5
    This is f.e. obtained with cdp neighbor detail?
    Thanks a lot.

  3. 9tut
    February 14th, 2012

    @czona: The IP address of S1/0 of R1 is 198.0.18.6. Usually the subnet mask of point-to-point serial connection is /30 -> we can guess the next hop is 198.0.18.5. But notice that the two commands
    “ip default-network 198.0.18.0
    ip route 0.0.0.0 0.0.0.0 198.0.18.5″
    has been configured in R1 configuration so you don’t need to type these commands.

  4. Eliza
    February 14th, 2012

    @Lero: how to spot the extra network in R1 which is needed to remove

  5. Eliza
    February 14th, 2012

    @9tut: is there any network in R1 which is needed to remove??

  6. Montee
    February 14th, 2012

    @Josh read this

    Report from show ip eigrp topology
    Notice that every route is preceded by a P. This means that the route is in the passive state,
    which is a good thing because routes in the active state (A) indicate that the router has lost its path to this network and is searching for a replacement. Todd Lammle.
    Once you say that you should have known that everything is up in your eigrp topology.

  7. 9tut
    February 14th, 2012

    @Eliza: If you see networks other than
    192.168.60.0
    192.168.36.0
    198.0.18.0
    192.168.77.0
    then you need to remove that network.

  8. noor
    February 14th, 2012

    hi 9tut
    how can add passive interface

  9. SUZ
    February 14th, 2012

    Hi Guys,

    I passed the exam yesterday. But couldn’t clear this sim
    I got the same sim. But all the four networks were advertised in R1. when i got the R3 under the AS number 12 from 22 and advertised the related networks it wasn’t pinging.

    later realized that instead the network subnet the interface of R1 connecting to R3 was advertised so i should have removed that and advertised with proper wildcardmask i guess.

    Just sharing my experience. Thank god i passed even after failing with this sim.

  10. Josh
    February 14th, 2012

    @Montee

    Really? You’re saying that I made it harder than it was? I know I had all the correct networks advertised and I still could not ping the ISP router – the main requirment for the lab. I could ping from R3 to R1 and R1 to ISP, but not from R3 to ISP.

    For that reason, I had to assume the EIGRP routes were not properly being exchanged – but if they are supposed to say “p” then maybe I missed something in the configuration. Are you sure about that?

  11. Andre Ero
    February 15th, 2012

    Hi Guys, Please to all those who have written the exams (even if you passed or failed), having to put the whole “show commands” in ones head isn’t easy, so please i would want to know if the ” help context (i.e “space bar ?” or “?”) and the auto-complete (“Tab”) works in all the sims? Please your replies would be really appreciated. Thanks

  12. justbnme
    February 16th, 2012

    Thanks 9tut for your insight and those of you who posted comments and feedback on the CCNA exam. I took my test today and scored an 881. It would not have been possible without all of the feedback and tips provided on your site. You can count on me to be a financial contributor so that others can benefit from your site as well.

  13. billy
    February 16th, 2012

    Please somebody can tell me about exam. Must we type on R1 the command :
    ip default-network 198.0.18.0
    ip route 0.0.0.0 0.0.0.0 198.0.18.5

  14. Sameer
    February 17th, 2012

    Scored 907 today. Thanks 9tut.com

  15. maja
    February 18th, 2012

    @9tut
    in order to advertise static/connected routes do you have to configure:
    R1(config)#router eigrp 212
    R1(config-router)# redistribute static/connected?

    BTW ISP router doesn’t have eigrp configured and that’s why you can’t ping
    Just try to put static route on ISP “ip route 192.168.0.0 255.255.0.0 198.0.18.6″ and it will work

  16. 9tut
    February 19th, 2012

    @maja: This is CCNA and we haven’t learned about redistribute command so don’t use it.

  17. maja
    February 19th, 2012

    @9tut
    so it is enough to put “ip default-network 198.0.18.0″ or “ip route 0.0.0.0 0.0.0.0 serial1/0″
    and “passive-interface se1/0″?
    Thanks

  18. 9tut
    February 19th, 2012

    @maja: These commands have already been configured so you don’t need to type them.

  19. Techy
    February 19th, 2012

    What changes are required to Ping ISP from Router 3? I can ping ISP from Router 1 but not from Router 3. Any suggesion please!!

  20. Techy
    February 19th, 2012

    @ Maja – Setting “ip route 192.168.0.0 255.255.0.0 198.0.18.6″ on ISP router helped to ping ISP from Router 3 –
    A further detail will be appreciated.

  21. pathseeker
    February 19th, 2012

    R1 has no connectivity to R2 because the interface se0/0 ip address not set on it but R2 has ip address… Let me know if i saw incorrect….cheerz….

  22. Welnino
    February 20th, 2012

    @9tut

    Kindly tell how would be able to ping ISP from R2, R3, or R4.

    we can ping ISP from R1 but not others. do we leave it as it is or we have to write commands to be able to ping ISP from routers other than R1 ???????????

    kindly clarify in detail
    thanks

  23. Irfan
    February 20th, 2012

    Passed today 960/1000 , same lab with slight difference of eigrp number and ip address

  24. Josh
    February 21st, 2012

    I just took the exam last week and just barely failed. This lab was one that was troublesome.

    The first thing is that the physical topology was different on the actual test, but I did the lab exactly like is shown above. I still could not ping the ISP router from the router that was added into the network and thought the passive interface maybe an issue. However, when I tried to enter the command I received “This command is not used in this simulation”.

    I have a CCIE at work and I discussed this issue with him. He thinks that I may have needed to configure NAT on R1 to enable EIGRP routes to communicate with the static public network. Has anyone else had this issue or any thoughts about this lab? I’m taking it again in 48 hours and am just wondering.

    Thanks

  25. Ika
    February 21st, 2012

    Will the IP table also be in the real exam?

  26. Welnino
    February 21st, 2012

    @Irfan

    congratz

    plz tell me if we have to ping ISP from all the routers in EIGRP lab
    and do we have to create static route ???????????????????????????????????????????????/

  27. Helloboy
    February 22nd, 2012

    @josh
    I took the exam last week as well , i scored 815, pretty gutted, I was having problems with the EIGRP lab because it asked me to ping the ISP router and i was unable to ping the router. I changed all the numbers and put in all the networks correctly but i was still unable to ping the ISP router.

    Also for some reason when i did show ip route, i was unable to see any of the networks with a D on the left hand side of it. That means that EIGRP has not exchanged the routes with the R1, but i did everything correctly in terms of advertisng the routes,

    Does anyone know why the D symbol on the left hand side ddint show up?

    Ps I am taking the exam in less than 12 hours, I will report back to you guys shortly. I am realyl concerned because i had to go next because i was wasting time and still i was unable to ping the damn isp router

  28. Josh
    February 22nd, 2012

    @Helloboy

    Yep, that’s exactly the same question I got.

    Show ip route is not what you want to use. You should use sh ip eigrp topology. However, it will show you a “p” next to all the routes – which is how it’s supposed to be – I think.

    Anyway, I’ve got to guesses.

    1. The passive interface mentioned above may actually be on R3 in the case above (Although my exam topology was different and R3 would have been called ENG)

    2. NAT needs to be configured on R1.

    Option 2 really stands out to me. Imagine I ping from R3 to the ISP IP address. ICMP will travel to R1 and then out the default route to the ISP. But the ISP router as no route for my private network so the echo replay gets dropped, most likely at R1.

    The part that really ticks me off is that this is the EIGRP lab, not the NAT lab; I wasn’t even thinking along those lines while taking my exam. Maybe I should have been but I wasn’t’ – I was simply concerned with EIGRP, nothing else, and I think Cisco won!

  29. Helloboy
    February 22nd, 2012

    @Josh
    For my lab, i only had access to router 3 and the main router, it was indicated by the dotted line (console cable) and did not have access to other routers, The reason that the EIGRP routes didnt show up is because the passive interface would have been enabled, I totally did not check this at all. Plus i must have made a rookie mistake of not advertising the routes on the both routers for the link that conencts them.

    Just tried it with the sim, and ran Sh ip route it all works well. I have never used the Show ip eigrp topology in any labs at all, this is the first time i have come across it. I dont know why but very strange.

    The first time you do the exam its very scary not because you dont know the answers but, the fear of lack of time or spending too long and missing out on later questions, When i go in tommrow, I will briskly get on with it. Its definately gonna be a pass.

    TBH i dont think that there is an NAT involved because NAT would have to be configured ont eh main router which connects to the ISP. plus they do not give you any pool of outside address to configure that,

  30. Aroma
    February 22nd, 2012

    Oh !! I’m got the same question as Helloboy got, I scored 815 as well – -”

    I’m thinking same Josh that this is EIGRP lab but it would need to configure NAT on R1 to be able to ping the ISP router from other router.

    Do anyone know the real answer for this question ?

    Thanks

  31. Helloboy
    February 22nd, 2012

    @Aroma
    Just checked the Sim that is posted on here, there is some sort of error as the ISP router is the DTE end, Where as it should be the DCE and sending down a clock rate. Right now the router 1 is sending down the clock rate, Thats probably the reason that its not workingon the simulator. I can ping up to the serial interface on the R1 which is connecting to the ISP, because of the above issue, it will not connect any further.

    However I will let you guys know tommrow what i acutally get

  32. Julia
    February 22nd, 2012

    Passed CCNA exam today. Thaks to Collisio dump and 9tut. SIMs eigrp, acl, vtp. 2-3 new questions. Good luck to all!

  33. czona
    February 22nd, 2012

    I´m not sure in this thing, but i made this. Router 3 successfully ping ISP router. You must do it with NAT. Below is the code from PT. Enjoy :)

    R1(config)#ip nat inside source static IP_1 IP_2
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip nat inside
    R1(config-if)#exit
    R1(config)#interface serial 1/0
    R1(config-if)#ip nat outside

  34. Welnino
    February 22nd, 2012

    @ *******9TUT**********

    plz clarify my question regarding EIGRP lab ,

    do we have to configure a static route on R1 to ping ISP from R2,R3, and R4??????????

    some people are saying that we have to use NAT ?????

  35. czona
    February 22nd, 2012

    @Welnino
    The NAT is needed, because there is a registered address. Ping isn´t possible, because the private address is can´t be routed on the ISP (public address). You mus´t use NAT.

  36. Welnino
    February 22nd, 2012

    @czona

    i checked the NAT config u published here..
    what shall be the Ip 1 and IP 2 in this command ?

    ip nat inside source static IP_1 IP_2

    ????? thanks again

  37. czona
    February 22nd, 2012

    IP_1: R3
    IP_2: ISP

  38. Welnino
    February 22nd, 2012

    thanks alot !

    JAZAK ALLAH

  39. pitt29
    February 22nd, 2012

    czona
    your suggestion working fine from R3 but won’t help for R2+R4.
    because ISP int s0/1/0 doesn’t participant in EIGRP we should insert the command:
    “ip route 192.168.0.0 255.255.0.0 198.0.18.6″ on ISP as @Techy said.
    ISP Router doesn’t know “192.168.x.x” network and it drop all pings(traffic) from this networks.

    you can try it – it works fine
    Hope i’m not confusing anyone…

  40. czona
    February 22nd, 2012

    @pitt29

    You aren´t right! In real world, it´s not possible to statically routing on ISP. ISP is the router of provider. I wrote there just a suggestion for R3. It´s a static NAT. If you would ping to ISP from R2 or from other routers, you must type similary on other routers, or use a PAT. Because you have a pool of private address and just one registered address. :) I hope it´s helpful for you.

  41. czona
    February 22nd, 2012

    I think, this solution by Techy is possible because it´s just Packet Tracer! Perhaps, and i´m afraid that on the real exam it´s not possible (type any code on ISP router). Sorry for my english!

  42. czona
    February 22nd, 2012

    Here is the solution in PT by me:

    R1#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#ip route 0.0.0.0 0.0.0.0 IP_ISP
    R1(config)#access-list 5 permit 192.168.0.0 0.0.255.255
    R1(config)#ip nat inside source list 5 interface serial 1/0 overload

    R1(config)#interface serial 1/0
    R1(config-if)#ip nat outside
    R1(config-if)#exit

    R1(config)#interface serial 0/0
    R1(config-if)#ip nat inside
    R1(config-if)#exit

    R1(config)#interface serial 0/1
    R1(config-if)#ip nat inside
    R1(config-if)#exit

    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip nat inside
    R1(config-if)#end

    It´s possible that it´s no the right answer, but I solve this problem by this way. :)

  43. czona
    February 22nd, 2012

    Solution no.2.:

    R1(config)#ip route 0.0.0.0 0.0.0.0 serial 1/0
    R1(config)#ip nat pool czona IP_ISP IP_ISP netmask 255.255.255.255
    R1(config)#access-list 12 permit 192.168.0.0 0.0.255.255
    R1(config)#ip nat inside source list 12 pool czona overload

    R1(config)#interface serial 1/0
    R1(config-if)#ip nat outside
    R1(config-if)#exit

    R1(config)#interface serial 0/0
    R1(config-if)#ip nat inside
    R1(config-if)#exit

    R1(config)#interface serial 0/1
    R1(config-if)#ip nat inside
    R1(config-if)#exit

    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip nat inside
    R1(config-if)#end

    In the “ip nat pool” IP_ISP is two times, because it´s a range from to. Netmask is 255.255.255.255, therefore the IP address must match (it´s not a network address but IP of interface).

  44. Chris
    February 23rd, 2012

    @Josh
    I see passive-interface in this lab on the sh ip eigrp topology; however when I run debug eigrp packets i definately get Hello send and receive. There may be a glitch in the lab and/or the test; however running the debug command will tell you whether you are receiving packets or not. Dont forget to escape debug “no debug all”.

  45. Chris
    February 23rd, 2012

    @Josh
    I looked into this passive-interface thing. The P that you are seeing simply means that route is in a passive state; which means that the router is NOT performing a route recomputation. If there are feasible successors a router never goes into active state. I confirmed this on my production network and all routes are in passive states, everything is functioning normally. So there is a difference between an interface being a Passive-Interface and a route being in a passive state. Hope this helps. Good luck on the test.

  46. effi pak
    February 23rd, 2012

    @czona
    i am wonder i have check your configurations and it works, the question is y it is not mention in question to configure Nat and Ping ISP…???
    i m going to attend exam tomorrow, i just see your solution its very helpful n i will keep this in mind..
    thanks

  47. Welnino
    February 23rd, 2012

    @czona

    any one of the 2 proposed solution above works ????????
    right!

  48. Welnino
    February 23rd, 2012

    @czona

    i have tried this configuration which u mentioned and its working for R3 :) Thanks

    R1(config)#ip nat inside source static IP_1 IP_2
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip nat inside
    R1(config-if)#exit
    R1(config)#interface serial 1/0
    R1(config-if)#ip nat outside

    IP_1: R3
    IP_2: ISP

  49. Jinys
    February 23rd, 2012

    any one know if we have to set the static route (to allow icmp) on real exam??

    Hope for a fast answer, tomorrow i will take my ccna-exam!

    thanks in advance!

  50. czona
    February 23rd, 2012

    Try to write “show running-config”. If there is, you don´t must configure a static route!

Comment pages
1 15 16 17 18 19 77 29
  1. No trackbacks yet.
Add a Comment