Home > Frame Relay – GNS3 Lab

Frame Relay – GNS3 Lab

July 30th, 2011 Go to comments

In this article we will create a Frame Relay in GNS3 to learn how to configure Frame-Relay.

Note: If you need to revise your Frame Relay knowledge, we recommend you to read our Frame Relay tutorial first.

First we create 4 routers and link them as follows:

Frame_Relay_Topology.jpg

IOS used in this lab: c2600-bin-mz.123-6f.bin

Configure IP addresses

First we will assign IP addresses for all relevant interfaces. Notice that R1 will be Frame-Relay switch in this lab so its interfaces don’t need IP addresses.

On R0:

R0#configure terminal
R0(config)#interface s0/0
R0(config-if)#ip address 192.168.1.1 255.255.255.0
R0(config-if)#no shutdown

On R2:

R2#configure terminal
R2(config)#interface s0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown

On R3:

R3#configure terminal
R3(config)#interface s0/0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#no shutdown

Configure Frame-Relay (using Inverse ARP)

To configure Frame-Relay on R0, R2 and R3 we need to enable Frame-Relay encapsulation and specify a type of LMI (ansi – in this case). Notice that Inverse ARP is enabled by default on Cisco routers so we don’t need to type anything to activate it.

R0,R2,R3(config)#interface s0/0
R0,R2,R3(config-if)#encapsulation frame-relay
R0,R2,R3(config-if)#frame-relay lmi-type ansi

Configure R1 as a Frame-Relay switch

In this lab R1 will be configured as a Frame-relay switch so no IP address is required.

Turn on Frame-Relay switching feature on R1:
R1(config)#frame-relay switching

On each interface we must specify how the frame will be proceeded. In practical, the Frame-Relay switch (R1) is placed at the ISP side so its interfaces should be set to DCE.

R1(config)# interface s0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay intf-type dce
//This command specifies the interface to handle LMI like a Frame Relay DCE device.
R1(config-if)#clock rate 64000
R1(config-if)#frame-relay route 102 interface Serial0/1 201
(will be explained later)
R1(config-if)#frame-relay route 103 interface Serial0/2 301

The command frame-relay route 102 interface Serial0/1 201 means frame-relay traffic come to R1 which has a DLCI of 102 will be sent to interface Serial0/1 with a DLCI of 201.

Note: Data link connection identifiers (DLCIs) are numbers that refer to paths through the Frame Relay network. They are only locally significant.

Continue configuring s0/1 & s0/2 interfaces (same as s0/0)

R1(config)# interface s0/1
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay intf-type dce
R1(config-if)#clock rate 64000
R1(config-if)#frame-relay route 201 interface Serial0/0 102

R1(config)# interface s0/2
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay intf-type dce
R1(config-if)#clock rate 64000
R1(config-if)#frame-relay route 301 interface Serial0/0 103

Use the show frame-relay map command to display the current map entries for static and dynamic routes

R0#show frame-relay map

Frame_Relay_R0_show_frame-relay_map.jpg

By default, Cisco uses Inverse ARP to map remote IP address of the PVC with the DLCI of the local interface as we can see here. From the output above we learn that DLCI 102 is set on Serial0/0 of R0 and mapped with 192.168.1.2. The status of this connection is “dynamic” and “active”, which means it is operating correctly.

The outputs of this command on other routers are shown below:

Frame_Relay_R2_show_frame-relay_map.jpg

Frame_Relay_R3_show_frame-relay_map.jpg

Notice that you will only see the “map” at two ends. If we issue this command on Frame-Relay switch (R1 is this case) it will show nothing.

The show frame-relay pvc command is used to display the status of all configured connections, traffic statistics, BECN and FECN packets received by the router.

Frame_Relay_R0_show_frame-relay_pvc.jpg

Frame_Relay_R1_show_frame-relay_pvc_1.jpg

Frame_Relay_R1_show_frame-relay_pvc_2.jpg

Frame_Relay_R2_show_frame-relay_pvc.jpg

Frame_Relay_R3_show_frame-relay_pvc.jpg

Use the show frame-relay lmi to display LMI traffic statistics (including LMI type, status messages sent and invalid LMI messages)

Frame_Relay_R0_show_frame-relay_lmi.jpg

Frame_Relay_R1_show_frame-relay_lmi.jpg

Frame_Relay_R2_show_frame-relay_lmi.jpg

Frame_Relay_R3_show_frame-relay_lmi.jpg

Pings from R0 to R2 & R3 are successful.

Frame_Relay_R0_ping_R2.jpg

Frame_Relay_R0_ping_R3.jpg

However ping from R2 to R3 is unsuccessful. It means that customers cannot see each other. This is because the split horizon rule: “A router never sends information about a route back in same direction which is original information came”. To overcome this problem we can configure subinterfaces on R0.

Frame_Relay_R2_ping_R3.jpg

Comments (115) Comments
Comment pages
  1. Mike
    January 6th, 2013

    i tried to fallow this lab doesn’t works!!!!!!!!!!!!!! What is the catch????????????????????????????????????????

  2. gopinathan
    January 11th, 2013

    hi 9tut ,

    you guys rock ty can you send me latest dump of ccna
    gopi112006@gmail.com

  3. Abdu
    January 18th, 2013

    there is a typo :
    FRS(config-if)#frame-relay intf-type dce not

    R1(config-if)#encapsulation lmi-type dce

  4. naani
    January 20th, 2013

    Hey ty, nice material.

  5. Steven
    January 23rd, 2013

    Abdu is correct. The command has a typo. Other than that great tutorial, and thanks

  6. S12
    February 1st, 2013

    @J100
    adding eigrp 1 makes show frame-relay map to work.. nice one!

  7. nk
    February 10th, 2013

    please please send me the latest dumpts to kandkur.nikhil@gmail.com … thnx

  8. 9tut
    February 17th, 2013

    @Abdu: Thanks for your detection. I updated it!

  9. GUN
    February 24th, 2013

    Just update

    R1(config-if)#frame-relay lmi-type ansi
    R1(config-if)#frame-relay intf-type dce

    And bring up serial0/0, 0/1 and 0/2 on R1

    no sh

  10. Perry
    February 25th, 2013

    I’ve seen this lab before and it’s always programmed the way you guys have it: With a PVC between R0 and R1 and another between R0 and R3, but no PVC between R2 and R3

    Is there a specific reason you did not program a PVC between R2 and R3?

  11. Anonymous
    February 28th, 2013

    Can you show us how to configure a subinterface to make pinging between r2 and r3 possible?

  12. lavas
    February 28th, 2013

    hey is there this lab in CCNA Exam ?

  13. Correction
    March 12th, 2013

    encapsulation lmi-type ansi

    Should be

    frame-relay lmi-type ansi

  14. Manoj
    March 18th, 2013

    Hello frndz….(frame-relay switching) is not working on router in packet tracer.

  15. kalle
    March 19th, 2013

    Taking the CCNA in a few weeks..this site along with CBT has been great for studying. Can you please send the latest dump to kallen0969@gmail.com ? Thanks

  16. hello M S Tejas
    March 20th, 2013

    why is the farm-realy not working in packer tracer ? where is that command came from i never came a cross it any help ple

    R1(config-if)#encapsulation lmi-type dce

  17. 9tut
    March 28th, 2013

    @hello M S Tejas: Sorry, the correct command should be:
    R1(config-if)#frame-relay intf-type dce
    We updated this lab!

  18. M.ELNaggar
    March 30th, 2013

    Guys can any 1 tell me where i can download IOS c2600-bin-mz.123-6f.bin??? thx

  19. Bigdaddy378
    April 24th, 2013

    It works great

  20. Mistro50
    May 7th, 2013

    Is this Fram-Relay on the ICND2 Exam?

  21. medo
    May 10th, 2013

    where is the icdn2 fram relay sim?

  22. Anonymous
    May 31st, 2013

    Anyone finding it difficult to see the results check if all the serial interfaces are up in R1. Probably they missed to include no shutdown command in the above lab for Router R1..

  23. cgates
    June 16th, 2013

    Router R0 to R2 and R3 ping fine, But router R3 to R2 not ping……….

  24. Sergio
    July 6th, 2013

    Works fine with “no shutdown” commands on each interface of the R1 and “no ip split-horizon” on R0!!!! Thank you 9tut (c3745-entbasek9-mz.124-5a.image-used)

  25. Driver
    July 18th, 2013

    I am using cisco packet tracer and can’t configure R1 as frame relay switch….I am using generic router….can anyone help?

  26. Meatwagon
    July 21st, 2013

    Driver,

    Use the WAN Emulation -> Cloud PT – then setup FR

  27. Meatwagon
    July 21st, 2013

    Driver,

    Use the WAN Emulation -> Cloud PT – then setup FR under the “config” tab. PT is very limited and will not allow you to configure a Router as a FR Switch.

  28. wgz
    August 8th, 2013

    How can I get a operation system so I can use GNS3 simulator?

  29. shashi
    August 14th, 2013

    To wgz,
    you don’t need a separate operating system to use GNS3 simulator.
    Just download latest one on the http://www.gns3.com site on your computer.

  30. shashi
    August 14th, 2013

    sry,,,from http://www.gns3.net

  31. Anthony
    August 16th, 2013

    Could you guys send me the lates dumps to anthony_mj17@hotmail.com please!?
    Thanks people!

  32. codifier
    August 17th, 2013

    Nice refresher on Frame Relay. Worked perfectly on GNS3, thank you.

  33. chanaka
    August 18th, 2013

    Hi 9tut,

    Please tell me how can put R1 as a frame-relay switching
    this command is not working on packet tracer

  34. chanaka
    August 18th, 2013

    Also R1(config-if)#frame-relay intf-type dce //This command specifies the interface to handle LMI like a Frame Relay DCE device.
    not working in pkt tracer

  35. keith geminus
    August 26th, 2013

    can anyone help with where to download cisco 2621xm ios

  36. Anonymous
    August 30th, 2013

    I would suggest “no keepalives” on the interface

  37. Kwame
    August 30th, 2013

    Is it possible to get gns3 on ipad mini or iPhone 4?

  38. vadimz
    September 25th, 2013

    Nice info. Seems to be. But looks like one has to spend more time trying to figure out how to run those sim labs, gns3, etc. than just learn the basic material. Unordered links, some mish-mash, pretty chaotic. I tried to figure it out but gave up. Except that just reading labs no way to really run sims or gns ( what the difference, anyway?). Was it difficult to just add some basic info on how to run this staff? Or that was an idea – make one spent one or two days just figuring all this mess out before concentrating on learning?

  39. iqbal
    September 27th, 2013

    at R1 on each interface should have no shut command.

  40. jayesh patel
    October 23rd, 2013

    how to configure subinterface to ping R0 to R3 please replay fast

  41. Ali
    January 27th, 2014

    Thanks man ,it worked for me

  42. Anonymous
    January 27th, 2014

    @Ali did it came in ur exam??

  43. Arshad
    March 5th, 2014

    Please send me latest update dumps to my email if anyone have arshadraja17@yahoo.com

  44. Anonymous
    March 30th, 2014

    Please send me the latest dumps at jot@cablespeed.com

  45. anonymous
    April 8th, 2014

    need latest dump for 100-101 exam

  46. kris
    June 11th, 2014

    Please I need latest dumps for ccna 200-120. Do help out by forwarding to arikris.okafor@yahoo.com

  47. NiDi
    June 19th, 2014

    Please send valid & latest dumps link to nvdakh79@live.com

  48. Last dump CCNA 200-120
    August 2nd, 2014

    Please I need latest dumps for ccna 200-120. Do help out by forwarding to igor.ritzmann@live.com

  49. Anonymous
    August 6th, 2014

    hi guys…
    I m going to give exam in the coming week.I will be thankful, if someone send me the latest dumps. My mail is kpkpkanhaiya@gmail.com.

Comment pages
Add a Comment