Home > CCNA EIGRP LAB Question

CCNA EIGRP LAB Question

January 25th, 2014 Go to comments

Question

After adding R3 router, no routing updates are being exchanged between R3 and the new location. All other inter connectivity and Internet access for the existing locations of the company are working properly.

The task is to identify the fault(s) and correct the router configuration to provide full connectivity between the routers.

Access to the router CLI can be gained by clicking on the appropriate host. All passwords on all routers are cisco.

IP addresses are listed in the chart below.

ccna_eigrp_sim

R1
Fa0/0: 192.168.77.33
S1/0: 198.0.18.6
S0/1: 192.168.60.25
S0/0: 192.168.36.13
R2
Fa0/0: 192.168.60.97
Fa0/1: 192.168.60.113
S0/0: 192.168.36.14
R3
Fa0/0: 192.168.77.34
Fa0/1: 192.168.60.65
Fa1/0: 192.168.60.81
R4
Fa0/0: 192.168.60.129
Fa0/1: 192.168.60.145
S0/1: 192.168.60.26

Answer and explanation

(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://www.9tut.com/eigrp-routing-protocol-tutorial. Note: You can download this sim to practice here: http://www.9tut.com/download/9tut.com_CCNA_EIGRP_sim_question.zip)

We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of R3 router, enter the show running-config command

ccna_eigrp_sim_show_run

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)

To solve this problem, we simply re-configure router R3 with the following commands:

R3>enable (you have to enter cisco as its password here)

R3#configure terminal

R3(config)#no router eigrp 22

R3(config)#router eigrp 212

R3(config-router)#network 192.168.60.0

R3(config-router)#network 192.168.77.0

R3(config-router)#no auto-summary

R3(config-router)#end

R3#copy running-config startup-config

Check R1 router with the show running-config command:

ccna_eigrp_sim_show_run_2

Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize R3 router

R1>enable (you have to enter cisco as its password here)

R1#configure terminal

R1(config)#router eigrp 212

R1(config-router)#network 192.168.77.0

R1(config-router)#end

R1#copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router R3 to other routers!

Modifications:

Maybe in this EIGRP Sim you will see the “passive-interface …” command somewhere in R1 configuration. If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this:

R1:

!
router eigrp 212
passive-interface s1/0
!

then we just leave it. Don’t use the “no passive-interface s1/0″ on R1 because the link between R1 & ISP doesn’t need EIGRP to run on it. A static route from R1 to ISP & “ip default-network” command in R1 are correct so that all the routers (R1, R2, R3, R4) can access the Internet.

(Note: The “ip default-network” command in R1 will advertise the static route of R1 (to go to the Internet) to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines in R1 configuration:

!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!

If you want to learn more about “ip default-network” command please read: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

I read recent comments and realized that you will see the “passive-interface” in the link between R1 & ISP router so just leave it.

Note: Also some readers confuse about if we should use the wildcard masks on the “network” statements under EIGRP process or not. For example should we use:

router eigrp 212
network 192.168.77.0 0.0.0.3

The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not make the routes conflicting. The “network …” command in EIGRP (and OSPF, RIP) does not means “advertise this network” but means “If I has interface(s) belongs to this network please turn on EIGRP on that interface. Therefore when you don’t use wildcard mask EIGRP will turn on EIGRP on all interfaces that belongs to the network you specify in the “network …” command.

You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same major networks but you don’t want to run EIGRP on all of them. For example if your router has 2 interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP on the first interface, you can type “network 192.168.30.0 0.0.0.15″ under EIGRP process.

Other lab-sims on this site:

CCNA Access List Sim

CCNA NAT SIM Question 1

CCNA NAT SIM Question 2

CCNA Frame Relay Sim

CCNA Configuration SIM Question (RIPv2 SIM)

CCNA VTP SIM

CCNA Drag and Drop SIM

CCNA Implementation SIM

 

Comments
Comment pages
1 5 6 7 8 9 77 29
  1. smith
    July 20th, 2011

    @obione,you might be right. i saw:

    ip default-network 198.0.18.0
    ip route 0.0.0.0 0.0.0.0 198.0.18.5

    i had to configure nat to permit hosts through private ip add. to reach isp.

    i got also a trouble in acl2 lab. (max 3 statement required )

    1. host D have to access finance web server(http).
    2. host D should not access finance web server for other services.
    3. core or lan hosts should be blocked to access finance web server.
    4. core or lan hosts ar allowed to access public web server.

    i had to make 2 statement ( i forgot the exacts ip add.)

    access-l 100 permit tcp host host eq 80
    access-l 100 permit ip any host

    however, thanks to 9tut for lab & questions.

  2. 9tut
    July 20th, 2011

    @obione: The other router can’t reach the ISP because they don’t have a route to it. In R1, we can configure
    ip default-network 198.0.18.0
    ip route 0.0.0.0 0.0.0.0 198.0.18.5
    to advertise this network to other routers so that they can reach ISP.
    In the exam you will see these commands with the “show run” command. Don’t try to use NAT in the exam because you are using a “simulator”, not a real router so it won’t work (and you will lose points).

  3. Phil
    July 20th, 2011

    hi all,

    after configuring the R1 this should be in the EIGRP 212 once i show run

    router eigrp 212
    network 192.168.36.0
    network 192.168.60.0
    network 198.0.18.0
    network 192.168.77.0
    no auto-summary

    ..because i add new router which is R3 (192.168.77.0)

    please clear this,,thanks!!!!

  4. obione
    July 20th, 2011

    @ smith

    what did u score 4 eigrp config.did the simulator accept the ” ip nat ….” command ?

    what did also score 4 access-list.tankx

  5. obione
    July 20th, 2011

    @9tut,

    since these commands are already configured on R1 and the routers cant get to ping the ISP. How does one get r2,r3,r4 to create a ping to ISP.TANX

  6. 9tut
    July 21st, 2011

    @Phil: Yes, you’re right :)

    @obione: If you can ping among R1, R2, R3, R4 then you will get full mark. Don’t worry about the ping to the ISP and don’t try to fix the “ip default-network” command.

  7. Anonymous
    July 21st, 2011

    i added the default-network and ip route command to test and routers can’t get to ISP

  8. Anonymous
    July 21st, 2011

    thats r2,r3,r4

  9. Anonymous
    July 21st, 2011

    it can get to r1 ip 198.0.18.6 but not 5

  10. Bolvek
    July 21st, 2011

    hi guys done the exam today had this simulation had to configure to eigrp 221 , had the vtp simulation and acl finance server simulation.

    There are quiet new question concerning ipv6 ( loopback equivalent of ipv6 ::/1 ) and few uestion concernind frame relay aswell (can’t recall now was way to happy pass with 983 thanks 9tut) will check the website if i can found what i’ve done today

    Gud luck everyone is you are getting ready

  11. obione
    July 22nd, 2011

    @9tut,

    thanx alot am very helpful.wish i can donate to your site someday .u guys are really motivating upcoming IT celebrities like me .THUMBS UP

  12. obione
    July 22nd, 2011

    @9tut,

    thanx alot am very GRATEFUL.wish i can donate to your site someday .u guys are really motivating upcoming IT celebrities like me .THUMBS UP

  13. Farrukh
    July 22nd, 2011

    i passed with 933. Thanks 9tut

  14. Ala
    July 23rd, 2011

    i had almost exactly like this question on my ccna exam, they asked me to add one router to the system and install eigrp in there, i did added it up, n i did eigrp configs, but it didnt work, i mean didnt get any adjuncy, i got confused, the time was ticking, so i skip the question n by the end i failed the exam, im gonna sit for the exam again next week.
    there were no passive interface, but i think the problem is exactly like this question, the network is not recongnized at R1, 9tut is the best before every exam, guyz try to remember all those sims in here before the exam, its more than enough to pass

  15. Saleh
    July 23rd, 2011

    hello all , this is useful links :
    (ACEM dump + TK v218 dump + software to open vce files + Sim questions)

    ACME dump :
    http://www.examcollection.com/cisco/Cisco.ACME.640-802.by.Prashanthan.v2011-04-20.356q.vce

    Tk V218(new version) dump :
    http://www.examcollection.com/cisco/Cisco.TestKiss.640-802.v2011-6-15.by.C3PO.142q.vce

    Visual_CertExam_Suite(software to open vce files):
    http://www.4shared.com/file/Lg8N7Wve/Visual_CertExam_Suite_19987_wi.html

    Sim questions:
    http://www.9tut.com/

    GOOD LUCK

  16. obione
    July 24th, 2011

    @ Ala,
    did u check the autonomus system numbers on the routers R1 and R3. pls i dont understand what u mean by adding one router to the system

  17. hashim
    July 24th, 2011

    @Saleh U are great! May God bless you alot
    Thanks alot for the links

  18. Roger
    July 25th, 2011

    hi guys!!

    I have the right configuration on R1 and R3 but can’t make ping from R3 and R4 to 198.0.18.5 but i can reach to 198.0.18.6 Pls, someone could answer this trouble??

  19. monisha
    July 26th, 2011

    why is that there is no ip for se0/0 int in router 1

  20. Anonymous
    July 26th, 2011

    roger, you need to add in 77.0 network into R1

  21. obione
    July 26th, 2011

    @ roger,
    read the comment sent to me by 9tut.if u can ping b/w r1,r2,r3,r4. u’ve got d configuration right

  22. Roger
    July 26th, 2011

    @ obione

    yes, i can ping b/w r1,r2,r3,r4. From r1,r2 i can ping to ISP but a can´t ping to isp from r3,r4 but i can reach 198.0.18.6

  23. khaleel
    July 27th, 2011

    i had my exams 2day but unfortunately i failed with a score of 696, please can someone help me with explanations of the following details so that i will prepare for my next canna exams because this is the 2nd time for me taking the exams and it seems like is the same problem with the first one.
    1. implement verify and troubleshoot NAT and ACLs in medium enterprise is 0%
    2.implement and varify WAN kins 0%
    please help me guys i really wana take the exams next week.

    tips for sim: VTP, ACL and EIGRP similar to 9tut, thanks guy.

  24. Phil
    July 27th, 2011

    @khaleel

    What topic are you hving problem..have you answer EIGRP and VTP 100%?

  25. Anonymous
    July 27th, 2011

    @khaleel, sorry but if you are getting a score of 700 you need to work on it more, not just retake and retake (or as the case maybe with alot of people here, just learning the answers, you need to understand the reason why)

    the fact you got 2x 0%s surely indicate a lack of fundamental knowledge, I would suggest holding off a retake and study more first.

    might sound harsh but unfortunately its the truth.

  26. Anonymous
    July 27th, 2011

    True talk Anonymous…Khaleel pls understand the concept first before retaking…best wishes

  27. tukhiem
    July 28th, 2011

    Hjx, pass ccna today but lab EIGRP not use static: ip route 0.0.0.0 0.0.0.0 198.0.18.5 and it’s report message: ..version not suppport this command…
    Hix, why that?

  28. Mad Dog
    July 28th, 2011

    Concur on changes in EIGRP, but concept still the same. Check your AS, use ping to check connectivity, instructions clearly state connectivity is working as required on …….
    VTP remains and ACL is there BUT make sure you read the variation notes provided in the practice sim on this site IF YOU WANT TO PASS!

    Having said that, I have taken the exam and failed twice over the last month. I have had serious test anxiety all my life and nothing has changed. Example, wrote out my ACL lab in three statements, then conf t, int f0/1, THEN I WENT BLANK ON HOW TO APPLY MY ACL! I had no concerns as I blasted through it the first time with no problem.

    Best advice, practice the sims over and over and then again, know your show commands, and take advantage of the links on this site that explain the theory behind the sim. I am lucky that I can subnet in my head very quickly, if you don’t understand block sizes, can’t count by 16 up to 256 easily, or know the powers of two such as 2 to the 8th = 256, then you have some work to do.

    I will post another comment about my experience and some issues within the tkv218.

  29. Mad Dog
    July 28th, 2011

    errata tkv218

    q93
    Which statement about access lists that are applied to an interface is true?

    A. you can apply multiple access lists with the same protocol or in different
    B. you can config one access list, per direction, per layer 3 protocol
    C. you can place as many access lists as you want on any interface
    D. you can apply only one access list on any interface

    Correct answer is B.
    source, Lammle, CCNA Study Guide, 7th edition, page 611

    “You can assign only one access list per interface per protocol per direction. This means you can have only one inbound access list and one outbound access list per interface”.

    Saw this one on 7/27, so it is relevant to study and know in the real world.

    q95

    Why would you utilize a block size of 64 instead of 32 when it says “as many as 30 hosts per subnet”.
    10.188.31.0/26
    That gives us a mask of 255.255.255.192
    2 bits on, 6 bits off, block size of 64-2=62 hosts
    2n x 2=4 subnets, 2 to the 6th=64-2=62 hosts

    vs.

    10.188.31.0/27
    A 27 mask gives us 3 bits on, 5 bits off, block size of 32-2=30 hosts
    3nx2=8 subnets, 2 to the 5th=32-2(network/broadcast)=30 hosts per subnet

    The key to this question is using specific info given which is “as many as 30 hosts” which should make us automatically think to ourselves “what block size will provide 30 hosts”? Always keeping in mind that block size minus 2 for our network and broadcast! If you can commit to memory CIDR, block size, bits on/off and the powers of 2 up to 256 (which is 2 to the 8th), the rest is gravy!

    Things I saw and remember…tkv218

    item 20,24,25,26,27,42,46,50,53,54,56,57,60,66-68,70,71,75-77,79-83,85,87-93(see notes above for q.93),96,97,100-104,106,113,115,118-121,123-128,134-138

    ipv6
    eigrp, same basic concept, AS, add routes, check by ping
    vtp
    acl with a twist, just study the variations provided with the sim on this site.

  30. Saud
    July 29th, 2011

    @ Mad Dog– can you please email the errata tkv218 mind the question does not match up 93 and 95 — so it look like have a different version of it please email me — zamanbadoolah@yahoo.com

  31. Gazal mughal
    July 31st, 2011

    hey guys can some body tell me about sim that we have to attend in 15 mints if we not complete the sim in 15 mints its automatic forwad pls help me i”m giving first time my ccna paper after 2 weeks

  32. alex
    August 1st, 2011

    ccna done,this lab is very easy….was my 5th question!..9tut gj!!!

  33. Jones
    August 2nd, 2011

    So we need the no auto-summary? And do we do anything with the ip-default network stuff? Or just know that it is there?

  34. Floccinaucinihilipilification
    August 3rd, 2011

    @9tut,
    If “ip default-network 198.0.18.0″ and “ip route 0.0.0.0 0.0.0.0 198.0.18.5″ these two commands are not configured in R1 then what we need to do?

  35. raju
    August 3rd, 2011

    please provide the latest links to prepare for the exam ,i want to take exam on 6th this month.

  36. Al
    August 4th, 2011

    Passed with 920 today, just know your concepts for this and you blow through it i promise. Just different AS number today, and couldn’t turn off passive interface, so dont waste your time trying. It has no affect on your score. I got a 100 percent on that.

  37. Floccinaucinihilipilification
    August 4th, 2011

    @Al,
    did you get passive interface in your sim in exam?

  38. obione
    August 4th, 2011

    @AL,
    PLS WHAT WAS UR ACL task

  39. Ferquiti
    August 5th, 2011

    DLO
    You must change the computer’s ip add according scheme

  40. SrkyBoy
    August 5th, 2011

    Passed today with 986 points. Everythning was the same except on router R1 one network statement was missing and had to be added. Subnet between R1 and R3.

    R1(config-router)#network 192.168.77.0

    I also configured interfaces fa0/1 and fa1/0 on R3 to be passive interfaces because they connect host and do not routing updates to be sent.

    To see protocol configurations you could use command show ip protocols.

  41. obione
    August 5th, 2011

    @Srkyboy,
    pls i don’t understand your explanation for this statement .i will be writing on sunday assist me please.what was your access-list task,am waiting 4 your response

    “I also configured interfaces fa0/1 and fa1/0 on R3 to be passive interfaces because they connect host and do not routing updates to be sent.”

    thanks

  42. Zeus
    August 5th, 2011

    im appearing in this week ..r the sims still same..eigrp , acl, vtp….???/
    plss reply…..

  43. SrkyBoy
    August 5th, 2011

    @obione

    I put interfaces fa0/1 and fa1/0 on router R3 to be passive because they were used to connect PCs on router and since PCs don’t exchange routing updates there was no need for R3 to waste bandwidth for sending routing updates over these interfaces. You don’t have to do this. Just follow instructions on this page. On my exam R2 was missing a statement for network between R2 and R3 (network 192.168.77.0) so i had to add it. Everything else was the same. Make sure to save configurations using copy running-config startup-config on every router after modifications.

    ACL question was similar to ACL2. There were 4 hosts and 2 servers. I had to allow HostA ONLY web access to Web Finance Server and block any other traffic to Web Finace Server from any other host (including HostA). My solution was

    access-list 101 permit tcp host 192.168.33.1 host 172.22.22.1 eq 80
    access-list 101 deny ip any host 172.22.22.1
    access-list 101 permit ip any any

    HostA address is 192.168.33.1, Web Finance Server is 172.22.22.1.

  44. obione
    August 5th, 2011

    @srkyboy,

    thanks am very grateful. u are the best

  45. JM
    August 6th, 2011

    Hi Everyone, there’s additional network on EIGRP simulation shown below in the exam, do I need to remove the additional network (network 192.168.61.0) configured in EIGRP on this case?

    R1
    Fa0/0: 192.168.77.33
    S1/0: 198.0.18.6
    S0/1: 192.168.60.25

    router eigrp 212
    redistribute static
    network 192.168.77.0
    network 198.0.18.0
    network 192.168.60.0
    network 192.168.61.0
    no auto-summary

  46. JM
    August 6th, 2011

    Please help everyone! thanks!

  47. 9tut
    August 6th, 2011

    @JM: Yes, you should remove it. There is no report about this additional network in the exam so far so you should double check before removing it.

  48. Moloy
    August 6th, 2011

    @Al,
    In your exam which interface of which router was passive?

  49. Istanbul
    August 6th, 2011

    I passed today with 828. Labs Acl, eigr,vtp

  50. obione
    August 6th, 2011

    @istanbul,

    pls what where d modifications in your sim

Comment pages
1 5 6 7 8 9 77 29
  1. No trackbacks yet.
Add a Comment