Home > CCNA Access List Sim 2

CCNA Access List Sim 2

February 15th, 2014 Go to comments

Question

A network associate is adding security to the configuration of the Corp1 router. The user on host C should be able to use a web browser to access financial information from the Finance Web Server. No other hosts from the LAN nor the Core should be able to use a web browser to access this server. Since there are multiple resources for the corporation at this location including other resources on the Finance Web Server, all other traffic should be allowed.

The task is to create and apply a numbered access-list with no more than three statements that will allow ONLY host C web access to the Finance Web Server. No other hosts will have web access to the Finance Web Server. All other traffic is permitted.
Access to the router CLI can be gained by clicking on the appropriate host.

All passwords have been temporarily set to “cisco”.
The Core connection uses an IP address of 198.18.196.65
The computers in the Hosts LAN have been assigned addresses of 192.168.33.1 – 192.168.33.254
Host A 192.168.33.1
Host B 192.168.33.2
Host C 192.168.33.3
Host D 192.168.33.4
The servers in the Server LAN have been assigned addresses of 172.22.242.17 – 172.22.242.30
The Finance Web Server is assigned an IP address of 172.22.242.23.
The Public Web Server is assigned an IP address of 172.22.242.17

access_list_sim2.jpg

Answer and Explanation

(Note: If you are not sure how to use access-list, please check out my access-list tutorial at: http://www.9tut.com/access-list-tutorial, also some modifications about the access-list have been reported so you should read the “Some modifications” section at the end of this question to understand more. You can also download this sim to practice (open with Packet Tracer) here: http://www.9tut.com/download/9tut.com_Access-list_sim2.pkt

Corp1>enable (you may enter “cisco” as it passwords here)

We should create an access-list and apply it to the interface which is connected to the Server LAN because it can filter out traffic from both Sw-2 and Core networks. The Server LAN network has been assigned addresses of 172.22.242.17 – 172.22.242.30 so we can guess the interface connected to them has an IP address of 172.22.242.30 (.30 is the number shown in the figure). Use the “show running-config” command to check which interface has the IP address of 172.22.242.30.

Corp1#show running-config

access_list_sim_show_running.jpg

We learn that interface FastEthernet0/1 is the interface connected to Server LAN network. It is the interface we will apply our access-list (for outbound direction).

Corp1#configure terminal

Our access-list needs to allow host C – 192.168.33.3 to the Finance Web Server 172.22.242.23 via web (port 80)

Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80

Deny other hosts access to the Finance Web Server via web

Corp1(config)#access-list 100 deny tcp any host 172.22.242.23 eq 80

All other traffic is permitted

Corp1(config)#access-list 100 permit ip any any

Apply this access-list to Fa0/1 interface (outbound direction)

Corp1(config)#interface fa0/1
Corp1(config-if)#ip access-group 100 out

Notice: We have to apply the access-list to Fa0/1 interface (not Fa0/0 interface) so that the access-list can filter traffic coming from both the LAN and the Core networks. If we apply access list to the inbound interface we can only filter traffic from the LAN network.

In the real exam, just click on host C and open its web browser. In the address box type http://172.22.242.23 to check if you are allowed to access Finance Web Server or not. If your configuration is correct then you can access it.

Click on other hosts (A, B and D) and check to make sure you can’t access Finance Web Server from these hosts.

Finally, save the configuration

Corp1(config-if)#end
Corp1#copy running-config startup-config

(This configuration only prevents hosts from accessing Finance Web Server via web but if this server supports other traffic – like FTP, SMTP… then other hosts can access it, too.)

Notice: In the real exam, you might be asked to allow other host (A, B or D) to access the Finance Web Server so please read the requirement carefully.

Some modifications:

Modification 1:

permit host B from accessing finance server access-list 100 permit ip host 192.168.33.2 host 172.22.242.23
deny host B from accessing other servers (not the whole network) access-list 100 deny ip host 192.168.33.2 172.22.242.16 0.0.0.15
permit everything else access-list 100 permit ip any any

Modification 2:

Only allow Host C to to access the financial server access-list 100 permit ip host 192.168.33.3 host 172.22.242.23
Not allow anyone else in any way communicate with the financial server access-list 100 deny ip any host 172.22.242.23
Allow all other traffic access-list 100 permit ip any any

Modification 3:

- Host C should be able to use a web browser(HTTP)to access the Finance Web Server access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
- Other types of access from host C to the Finance Web Server should be blocked
- All access from hosts in the Core or local LAN to the Finance Web Server should be blocked
access-list 100 deny ip any host 172.22.242.23
(because the requirement says we can not use more than 3 statements so we have to use “any” here for the hosts in the Core and hosts in local LAN)
- All hosts in the Core and local LAN should be able to access the Public Web Server * access-list 100 permit ip any host
(If the question asks this, surely it has to give you the IP of Public Web Server) but in the exam you should use “access-list 100 permit ip any any”

Modification 4:

Host C should be able to use a web browser to access the financial web server access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
Other types of access from host C to the finance web server should be blocked access-list 100 deny ip host 192.168.33.3 host 172.22.242.23
All hosts in the core and on the local LAN should be able to access the Public web server * access-list 100 permit ip any host
(The IP of Public Web Server will surely be given in this question) but in the exam you should use “access-list 100 permit ip any any”

* There are some reports about the command of “All hosts in the core and on the local LAN should be able to access the Public web server” saying that the correct command should be “access-list 100 permit ip any any”, not “access-list 100 permit ip any host (IP of Public Web Server)”. Although I believe the second command is better but maybe you should use the first command “access-list 100 permit ip any any” instead as some reports said they got 100% when using this command (even if the question gives you the IP address of Public Web Server). It is a bug in this sim.

(Note: Don’t forget to apply this access list to the suitable interface or you will lose points
interface fa0/1
ip access-group 100 out

And in the exam, they may slightly change the requirements, for example host A, host B instead of host C… so make sure you read the requirement carefully and use the access-list correctly)

I created this sim in Packet Tracer v5.2.1 so you can practice with it. You will need new version of Packet Tracer to open it (v5.1+).

accesslist_sim2_packet_tracer.jpg

Download this sim here

Notice: After typing the commands above, if you make a “ping” from other hosts (PC0, PC1, PC3) then PC4 (Finance Web Server) can still reply because we just filter HTTP traffic, not ICMP traffic. To generate HTTP traffic, select “Web Browser” in the “Desktop” tab of these PCs. When a web browser opens, type the IP address of Finance Web Server and you can see how traffic flows in Simulation Mode.

accesslist2_test_http.jpg

And notice that in the initial configuration of this sim the Core network can ping Finance Web Server. We have to create an access-list that can filter this traffic too.

Other lab-sims on this site:

CCNA NAT SIM Question 1

CCNA NAT SIM Question 2

CCNA Frame Relay Sim

CCNA Configuration SIM Question (RIPv2 SIM)

CCNA VTP SIM

CCNA EIGRP LAB

CCNA Drag and Drop SIM

CCNA Implementation SIM

Comments
Comment pages
1 32 33 34 35 36 63 41
  1. Bar
    February 5th, 2014

    jeff, if the sim wasn’t working properly, maybe u should contact cisco so they can refund you? by the way is the tab working in the sim?

  2. Jeff
    February 5th, 2014

    is there a command to remove access-list?

  3. Bar
    February 5th, 2014

    yes…
    no access-group (in, out)

  4. Bar
    February 5th, 2014

    no ip access-group in or out

    for example:
    conf t
    interface f0/0
    no ip access-group 101 out

  5. ebemusty
    February 5th, 2014

    Just put “no” infront of any command it will disable it ….

  6. Brandon
    February 5th, 2014

    Hello so are the sims now ACL 1, ACL2, and EIGRP? So there is no more VTP simulation?

  7. Bar
    February 6th, 2014

    do you guys know if we can use “tab” in the sim – to complete commands or do we have to write the full commands all the time?

  8. Brandon
    February 6th, 2014

    Hello everyone. So are the sims on the exam now ACL1, ACL2, Eigrp? IS VTP no longer a sim I might see? Any help would be great.

  9. Tommy
    February 7th, 2014

    Question folks..

    So the last two commands
    interface fa0/1
    ip access group 100 out

    Will we still type those two commands even if they ask us to permit host b for example?
    I know the three commands will change, but will the last 2 change to close out the sim?

    Please help!!!!!!

  10. Bar
    February 7th, 2014

    Tommy – yes.
    you need to include the access-list to the relevant interface – so the access-list would work.
    so yes – whatever access-list you make – you need to type the command ip access group XXX out/in – in this case – like you wrote – onto interface fa0/1

  11. CCNA in training
    February 7th, 2014

    @Bar @Tommy @cold @anyone please!!!!
    Hello Mates,

    I just found this website and I am taking my exam tomorrow morning. I wasn’t aware of the many modifications.

    Can someone help me out with similar to @Tommy question. for the last two commands for each scenario.

    -Permit Host B will have what 2 commands? Interface? Ip access group?
    -Only allow host c access to the financial server?
    -Host C should be able to use a web (http) browser?
    Host C should be able to use a web browser to access the financial server?

  12. TONY
    February 7th, 2014

    I am still working out this problem, I’ll help you in a few.

    Can anyone help out in the mean time?

  13. sharif
    February 8th, 2014

    Bar , you are wrong …
    the solved lab given above is 100% correct ..in the Question they asked that allow only host C to access finance web server using http … so they use
    “ip access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq www”

    and secondly they asked that block http access to finace web server from any other host so they use
    “ip access-list 100 deny tcp any host 172.22.242.23 eq www”

    dont think we are fool

  14. sharif
    February 8th, 2014

    Jeff are you mad , you dont know how to remove passive interface and you went for the exam

    command is
    router eigrp 212
    no passive-interface fa0/1

  15. Prakhar
    February 8th, 2014

    @Tommy @CCNA in training

    An access-list is just a list. It works only when we apply it to an interface. Even in a changed scenario you have to give these commands:

    interface fa0/1
    ip access group 100 out

    Which will apply it to outside direction on interface f0/1.

    Don’t forget to save your running config by giving: copy running-config startup-config command!

  16. Bar
    February 9th, 2014

    sharif,
    not from any other host – deny other access (exept web access) from host c.
    it was jeff’s sim – it has nothing to do with the original sim.

  17. Jeff
    February 10th, 2014

    @sharif,
    No i am not mad……i tried that command… it didn’t work…. i will be better prepared next time…

  18. Brandon
    February 10th, 2014

    Is the VTP simulation still on the exam? I heard conflicting reports that it is now ACL1? Anybody know?

  19. Mikle
    February 11th, 2014

    @9tut
    Hey what if t says Host D will be blocked?? What commands so we use then?

    This showed up on my friends sim today.

  20. 9tut
    February 11th, 2014

    @Mikle: Just use Host D IP address instead in three acl statements.

  21. saifi
    February 13th, 2014

    i had passed my ccna exam with 972/1000 score on 12 feb.
    the labs were acl1,acl2 and eigrp
    acl 1 (same as it is)
    eigrp (just change od AS and advertising a network (same as it is) with NO issue about passive interfaces and default network )
    acl 2 (with bit modification)

    “The task is to create and apply a numbered access-list with no more than three statements that
    -> will allow ONLY host A web access to the Finance Web Server.
    ->All other traffic from A to finance server is denied.
    ->All traffic from lan servers(B,C,D) and core to the Finance Web Server is denied.
    -> All other traffic is permitted to public server.

  22. Brandon
    February 13th, 2014

    Sailif So the ACL1 sim on the exam was the same as on here?

  23. Mike
    February 14th, 2014

    @Saifi

    So what was your 3 statements?

    Also was ACL1 the same?

    What was your drag and drop question?

  24. Jason
    February 14th, 2014

    Just finished my exam today.. The simulation question just came out acl1, acl2 and eigrp.. Same question regarding acl2 as mentioned by Saifi.. No drag and drop question..

  25. dp
    February 14th, 2014

    how many items does the exam have?

  26. Jason
    February 14th, 2014

    @dp

    only 51 questions in the exam.

  27. dp
    February 14th, 2014

    ok thanks!

  28. Anonymous
    February 14th, 2014

    I just passed my exam today 14 feb. I got acc. 1 and 2 sim and eigrp sim as well. My adversed to u guys is to keep calm all the questns dat are here are in the exam I nealy fork up becos of an uncessary pressure I inpuse on myself befor the exm. I got 917 anyways. Goodluk to u guys.

  29. flawless
    February 14th, 2014

    I just passed my exam today 14 feb. I got acc. 1 and 2 sim and eigrp sim as well. My adversed to u guys is to keep calm all the questns dat are here are in the exam I nealy fork up becos of an uncessary pressure I inpuse on myself befor the exm. I got 917 anyways. Goodluk to u guys.

  30. flawless
    February 14th, 2014

    I just passed my exam today 14 feb. I got acc. 1 and 2 sim and eigrp sim as well. My adversed to u guys is to keep calm all the questns dat are here are in the exam I nealy forked up becos of an uncessary pressure I inpuse on myself befor the exm. I got 917 anyways. Goodluk to u guys.

  31. saifi
    February 17th, 2014

    @mike
    no drag drop
    ACL 1 was same
    ACL 2 statments were
    The task is to create and apply a numbered access-list with no more than three statements that
    -> will allow ONLY host A web access to the Finance Web Server.
    ->All other traffic from A to finance server is denied.
    ->All traffic from lan servers(B,C,D) and core to the Finance Web Server is denied.
    -> All other traffic is permitted to public server.

  32. saifi
    February 17th, 2014

    @ brandon
    ACL1 was same

  33. mike
    February 18th, 2014

    hi Saifi,

    how did you answer this , All traffic from lan servers(B,C,D) and core to the Finance Web Server is denied.?

  34. Bar
    February 18th, 2014

    mike –

    All traffic from lan servers(B,C,D) and core to the Finance Web Server is denied.?

    access-list 100 deny ip any host 172.22.242.23 (the ip of the finance web server)

  35. Bar
    February 18th, 2014

    the 3 statements should be: (saifi’s sim)

    access-list 100 permit tcp host 192.168.33.1 host 172.22.242.23 eq 80

    access-list 100 deny ip any host 172.22.242.23

    access-list 100 permit ip any any

    (i used the ip addresses from the original sim – they can vary in the real test i guess)

  36. mike
    February 18th, 2014

    hi bar,

    can u check my acl base on saifi’s given?

    -> will allow ONLY host A web access to the Finance Web Server.
    ->All other traffic from A to finance server is denied.
    ->All traffic from lan servers(B,C,D) and core to the Finance Web Server is denied.
    -> All other traffic is permitted to public server.

    access-list 100 permit tcp host 192.168.33.1 host 172.22.242.23 eq 80
    access-list 100 deny ip host 192.168.33.1 host 172.22.242.23
    access-list 100 deny ip any host 172.22.242.23
    access-list 100 permit ip any host 172.22.242.17

    i come up with 4 lines, is it correct?

    thanks

  37. mike
    February 18th, 2014

    for the 2nd line he was very specific that all traffic from A would be deny except for the http (tcp)

    please advise i’ll take the 200-120 tomorrow

    thanks

  38. mike
    February 18th, 2014

    also in the last line he specify the host which is the public server…

    I think if the exam limit the answer to 3 lines only, your acl would be the perfect answer..

    thanks dude

  39. Bar
    February 18th, 2014

    you are correct, but remember that in the test – you can use only 3 statements not 4!
    so…if you can use only 3 – than you should use what i wrote:

    access-list 100 permit tcp host 192.168.33.1 host 172.22.242.23 eq 80
    access-list 100 deny ip any host 172.22.242.23
    access-list 100 permit ip any any

    your 4 statements are correct, but the requirement is to use only 3.

    good luck on your test tommorow…let us know how it went :)

  40. Ravi kanth
    February 18th, 2014

    If i want to block only host b from financial server (only pinging) ….then what is the command we supposed to use ???
    please post the answer…..

  41. Lori
    February 18th, 2014

    i passed everyone I had ACL1 Simlet same as on here.
    ACL2 same as here Host B (HTTP)
    Eigrp as 212

    Study the dumps and you will pass.

    Love

  42. Bar
    February 19th, 2014

    ravi – if you want to block host b (any kind of traffic) –

    access-list 100 deny ip host 192.168.33.2 host 172.22.242.23

    this will deny any kind of communication from host be to the server.

  43. Atif
    February 19th, 2014

    @ mike

    you can notice
    ->All other traffic from A to finance server is denied.
    ->All traffic from lan servers(B,C,D) and core to the Finance Web Server is denied

    above mentioned both questions are equally same
    your can use a single command ” access-list 100 deny ip any host 172.22.242.23″ to fullfill both questions

  44. Bar
    February 19th, 2014

    guys, i want to know on the technical side of the test – about the sims –
    can you switch between the routers on the test in the sim? i mean like in packet tracer? is the feel of this sim like packet-tracer? the commands? using “tab” and “?”
    is it easy to use?

  45. Atif
    February 19th, 2014

    i also have the same question as Bar

  46. BJones
    February 19th, 2014

    Bar,

    you will only be allowed to console in.

    On some sims you may have to telnet from device to device.

  47. BJones
    February 19th, 2014

    Atif,

    You will only be allowed to console in, you will not get a gui at all. the only thing you will be able to see is the CLI. Another thing.. You are limited in your command list.. IE… you cannot “?” or use tab in most situations. Hope this helps!!

    BJones

  48. BJones
    February 19th, 2014

    I would like to note that when I took the CCNA X back in Sept 30 13. I got this sim………I forgot that the cloud is connected to this (WHERE THE SECOND ROUTER IS IN THIS PACKET TRACER) and if you apply this ACL to the interface facing the pcs you will fail!

    You have to apply the ACL to the interface facing the servers.

    If you dont this will allow all traffic from the cloud to have access to the Financial Server..

  49. Bar
    February 20th, 2014

    when you have entered a configuration in one router, and then opened another router, and still haven’t saved the config in the first – you need to enter it again, or does it remember? i mean you can console one router and, then console another, and go back and forth between the routers like in packet tracer?

  50. cliff
    February 21st, 2014

    Pass ccna today acl 1 and 2 and eigrp was there. Only difference are the ip. This website is very helpful.

Comment pages
1 32 33 34 35 36 63 41
  1. No trackbacks yet.
Add a Comment