CCNA Access List Sim 2
Question
A network associate is adding security to the configuration of the Corp1 router. The user on host C should be able to use a web browser to access financial information from the Finance Web Server. No other hosts from the LAN nor the Core should be able to use a web browser to access this server. Since there are multiple resources for the corporation at this location including other resources on the Finance Web Server, all other traffic should be allowed.
The task is to create and apply a numbered access-list with no more than three statements that will allow ONLY host C web access to the Finance Web Server. No other hosts will have web access to the Finance Web Server. All other traffic is permitted.
Access to the router CLI can be gained by clicking on the appropriate host.
All passwords have been temporarily set to “cisco”.
The Core connection uses an IP address of 198.18.196.65
The computers in the Hosts LAN have been assigned addresses of 192.168.33.1 – 192.168.33.254
Host A 192.168.33.1
Host B 192.168.33.2
Host C 192.168.33.3
Host D 192.168.33.4
The servers in the Server LAN have been assigned addresses of 172.22.242.17 – 172.22.242.30
The Finance Web Server is assigned an IP address of 172.22.242.23.
The Public Web Server is assigned an IP address of 172.22.242.17
Answer and Explanation
(Note: If you are not sure how to use access-list, please check out my access-list tutorial at: http://www.9tut.com/access-list-tutorial, also some modifications about the access-list have been reported so you should read the “Some modifications” section at the end of this question to understand more. You can also download this sim to practice (open with Packet Tracer) here: http://www.9tut.com/download/9tut.com_Access-list_sim2.pkt
Corp1>enable (you may enter “cisco” as it passwords here)
We should create an access-list and apply it to the interface which is connected to the Server LAN because it can filter out traffic from both Sw-2 and Core networks. The Server LAN network has been assigned addresses of 172.22.242.17 – 172.22.242.30 so we can guess the interface connected to them has an IP address of 172.22.242.30 (.30 is the number shown in the figure). Use the “show running-config” command to check which interface has the IP address of 172.22.242.30.
Corp1#show running-config
We learn that interface FastEthernet0/1 is the interface connected to Server LAN network. It is the interface we will apply our access-list (for outbound direction).
Corp1#configure terminal
Our access-list needs to allow host C – 192.168.33.3 to the Finance Web Server 172.22.242.23 via web (port 80)
Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
Deny other hosts access to the Finance Web Server via web
Corp1(config)#access-list 100 deny tcp any host 172.22.242.23 eq 80
All other traffic is permitted
Corp1(config)#access-list 100 permit ip any any
Apply this access-list to Fa0/1 interface (outbound direction)
Corp1(config)#interface fa0/1
Corp1(config-if)#ip access-group 100 out
Notice: We have to apply the access-list to Fa0/1 interface (not Fa0/0 interface) so that the access-list can filter traffic coming from both the LAN and the Core networks. If we apply access list to the inbound interface we can only filter traffic from the LAN network.
In the real exam, just click on host C and open its web browser. In the address box type http://172.22.242.23 to check if you are allowed to access Finance Web Server or not. If your configuration is correct then you can access it.
Click on other hosts (A, B and D) and check to make sure you can’t access Finance Web Server from these hosts.
Finally, save the configuration
Corp1(config-if)#end
Corp1#copy running-config startup-config
(This configuration only prevents hosts from accessing Finance Web Server via web but if this server supports other traffic – like FTP, SMTP… then other hosts can access it, too.)
Notice: In the real exam, you might be asked to allow other host (A, B or D) to access the Finance Web Server so please read the requirement carefully.
Some modifications:
Modification 1:
permit host B from accessing finance server | access-list 100 permit ip host 192.168.33.2 host 172.22.242.23 |
deny host B from accessing other servers (not the whole network) | access-list 100 deny ip host 192.168.33.2 172.22.242.16 0.0.0.15 |
permit everything else | access-list 100 permit ip any any |
Modification 2:
Only allow Host C to to access the financial server | access-list 100 permit ip host 192.168.33.3 host 172.22.242.23 |
Not allow anyone else in any way communicate with the financial server | access-list 100 deny ip any host 172.22.242.23 |
Allow all other traffic | access-list 100 permit ip any any |
Modification 3:
- Host C should be able to use a web browser(HTTP)to access the Finance Web Server | access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80 |
- Other types of access from host C to the Finance Web Server should be blocked - All access from hosts in the Core or local LAN to the Finance Web Server should be blocked |
access-list 100 deny ip any host 172.22.242.23 (because the requirement says we can not use more than 3 statements so we have to use “any” here for the hosts in the Core and hosts in local LAN) |
- All hosts in the Core and local LAN should be able to access the Public Web Server * | access-list 100 permit ip any host (If the question asks this, surely it has to give you the IP of Public Web Server) but in the exam you should use “access-list 100 permit ip any any” |
Modification 4:
Host C should be able to use a web browser to access the financial web server | access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80 |
Other types of access from host C to the finance web server should be blocked | access-list 100 deny ip host 192.168.33.3 host 172.22.242.23 |
All hosts in the core and on the local LAN should be able to access the Public web server * | access-list 100 permit ip any host (The IP of Public Web Server will surely be given in this question) but in the exam you should use “access-list 100 permit ip any any” |
* There are some reports about the command of “All hosts in the core and on the local LAN should be able to access the Public web server” saying that the correct command should be “access-list 100 permit ip any any”, not “access-list 100 permit ip any host (IP of Public Web Server)”. Although I believe the second command is better but maybe you should use the first command “access-list 100 permit ip any any” instead as some reports said they got 100% when using this command (even if the question gives you the IP address of Public Web Server). It is a bug in this sim.
(Note: Don’t forget to apply this access list to the suitable interface or you will lose points
interface fa0/1
ip access-group 100 out
And in the exam, they may slightly change the requirements, for example host A, host B instead of host C… so make sure you read the requirement carefully and use the access-list correctly)
I created this sim in Packet Tracer v5.2.1 so you can practice with it. You will need new version of Packet Tracer to open it (v5.1+).
Download this sim here
Notice: After typing the commands above, if you make a “ping” from other hosts (PC0, PC1, PC3) then PC4 (Finance Web Server) can still reply because we just filter HTTP traffic, not ICMP traffic. To generate HTTP traffic, select “Web Browser” in the “Desktop” tab of these PCs. When a web browser opens, type the IP address of Finance Web Server and you can see how traffic flows in Simulation Mode.
And notice that in the initial configuration of this sim the Core network can ping Finance Web Server. We have to create an access-list that can filter this traffic too.
Other lab-sims on this site:
@Bilbo
My over all score was 986… I only got 80% on “Network Device Security”, so maybe that was for the ACL sim, so maybe you are right and use the ” …. ip any any” for the EXAM … even though the ” … ip any host” works.
@this
yes, all sims were same format just different information, ie for ACL2, I had Host B instead of Host C and also the IPs were different…but concepts and steps should all be the same as examples here on 9tut.
For the Access list ,Is it exaclty the modification 3 ,that you deny all traffic from other host to server or,,we only deny the Web access ??
Hi, I passed the CCNA exam just now (972/1000). Sims: ACL 1 & 2, and EIGRP.
EIGRP Sim: 1) AS 22 -> AS 122 on the R2 router; 2) missing network on the central router. Just practice 9tut EIGRP simulation and you will be successful. I have got 100% for IP routing Technologies.
ACL 2 Sim Modification 3: My answer was (on the central router):
access-list 110 permit tcp host 192.168.33.1 host 172.22.118.18 eq 80
access-list 110 deny ip any host 172.22.118.18
access-list 110 permit ip any host 172.22.118.17
interface fa0/1
ip access-group 110 out
I have checked connections from PCs and was ok for my perspective. But in final results I have got only 80% for Network Device Security, and I suspect that my ACL list in this simulation was wrong, because I did not use as a third command: access-list 110 permit ip any any (as 9tut sugested in Modification 3).
@ceca congratzz… thn in eigrp lab if thy give private ip for host thn we can ping to isp r not….. or we hav to change the ip urself..? reply plzz.
@ceca wat dumps u prepared ?
Please Help, I’m taking CCNA exam next month. Kindly send me latest dump for ccna exam to my mail: jamaxis2000@yahoo.com
@zulqurnan:
I had 0% in 1 of the topics…i don’t know why..I asked the support in the usa if there was a technical error..but they said “no” it was my fault…
I had 0% in Network Device Security
@MJ….it was exactly the same steps for Mod 3….but in the test that I got it was for Host B
@Ceca … I did the same steps as you did and used the “host IP”, I also got 80% on “Network Device Security”….. so follow 9tut and use the “… ip any any)
@Hope .. I would think either all steps were not completed or you “exit” the sim before completing it … that is my thoughts..
i guess anonymous is right…
adn @ceca congrats dear…just requesting u kindly tell everyone abut dump from whcih u prepare for exam… tnx
@Anonymous
no I checked everything and saved the whole running-config.
In the ACL task host b was the host not c
hi passed today 1000/1000….. lab same s here 9tut… thanks 9tut and examcollection…..
Done for my Exam 200-120 thank you so much 9tut for simulation ,watson314, matthew exam c,Just review all the material,
Simulation from 9tut
ACL1-the same
ACL2-modification 3,Change IP
EIGRP AS anD IP,Remove and add
Dumps,
ExamC ,Watson,9tut
Thank you thank you
@deepark
Hi , could you explain me something about acl sim ?
In the acl sim 2, which the last command should use ?
the “permit ip any any” or “permit ip any host …”
Thanks a lot !!!
hey
if i will write the command “ip access list extended 100″ etc instead of “access list 100″ etc
it will be accepted as a good answer?
(it’s easier than writing every time “access list 100″ in the beginning and i can edit the sq numbers if i made a mistake)
@boy u shud use ” ip permit any any ” command as it works 100 % correct in acl lab….
gud luck
in exam thy will give public server ip but u hav to use ” ip permit any any ” command as it allows all host in lan to access public server…….. any dought…?????………….
@boy u will get same acl sim as here in 9tut. but u hav to c the concepts and commands in the router. as thy might change ip or numbers…
hello everyone…today at 10 july i passed my CCNA exma at last… i got 986 marks out of 1000…i prepared from watson, mathew and bilbeast…i prefered watson…its still valid 100%… and as far as about labs… they are same ACL1, ACL2 and EIGRP… and please one advice stay calm in exam no need to panic.. and when u do sims read it carefully… and i ACL modification ” permit ip any any” command should be applied…in the end thanks to Touseef Bhae, Zulqurnan my frend, 9tut and examcollection…
salam Hassan brother if you read my message please i need your help for the ccna keep in touch please walid_n@outlook.com
hi buddy,
Iam from Angola.
I passed my exame today, thanks to god i scored 917/1000.
most of the question were from 9tut and exame collection. thanks alot for your help.
now iam on my way to CCNP.
best regards for the forum and good comments poted.
salam every one first of all thanks to Allaha …..and thanks to my brother touseef …and thank all 9tut team or examcollection… ……………i passed 10 july i got 972 same watson dumps and same acl acl2 and eigrp.. dont be confuse only stdy dumps and peractice lab. i prefered watson…and 9tut ..,….
wa alaikum salaam walid…sure bro any time…
thts my mail walid… hassan_raza09069@yahoo.com
hi good ramadan every one in muslim. make me du aa i m going exsam 2morrow inshallah.
I have passed the exam with 986 today. Labs Acl, Acl2(modification 3) and eigrp (As 12 and IPs different). All questions from 9tut just a few from dumps e.g OSPFV2 vs OSPFV3. Read all topics from 9tut start with notes for understanding. After that master all the questions and its a guaranteed pass. Dumps can help to check on new questions e.g the one above and a few others. With 9tut info dumps are just something to assure you, you are ready. All the best feel free to raise any queries. Also check my comment on modification 3 on ACL2 page.
@9tut .. My argument on modification 3 is that “permit ip any any” is the best answer and its not a bug. The question always state that there are other servers and other resources even in the financial server. If we apply this “permit ip any host” that mean we don’t have any other permit statement to allow traffic to other servers and different resources in financial server. Based on the fact that we are limited to 3 statements we should use any any to cater for the two instances rather than permit access to web server only. kindly clarify on this and shed some light to upcoming candidates.
Thanks a lot 9tut ” As long as its on 9tut i can pass the exam !!”
Passed with 1000 last week. Thanks CBT nuggets, 9tut and Watson’s dump…! Got EIGRP sim with wrong AS number and missing network. Also one router had wrong network configured. The other simulation questions were Access Sim 2 and the NAT configuration. Study and do Watson’s dump multiple times until you get most of them correct. Then it should be a piece of cake..! Good luck!
Salam all, can any one tell me which sims are coming now adays i have planned to take exam next week.
Please reply me asap.
Thanks
if we do like this:
access-list extended PROVACISCO
permit ip host 192.168.33.3 host 172.22.242.23
deny ip 192.168.33.0 0.0.0.255 host 172.22.242.23 eq www
permit ip any any
int f0/0
ip access-group PROVACISCO out
is it ok ?
Kani, where do you get Watson’s dump?
Also, in the example above, to create the access list I can use the command “ip access-list extended 100″ , correct? then add my 3 statements with sequence numbers? I prefer this newer method and am wondering if this is a problem on the exam.
Thank you Hassan brother.
HI guys please any one with the dumps should please forward to wavanyinyako@yahoo.com
Hi, I have the real dumps ‘Pass4sure’ with this I have passed out CCNA on 1st July 2014, With 958/1000…….
All the question 307 & ACL 1 , 2 & EIGRP in PDF.
If anyone want to buy it, please mail me on balasaheb.deshmukh@gmail.com
could be MOd 4 like I shown below? :
access-list 100 deny tcp host 192.168.33.3 host 172.22.242.23 neq 80
access-list 100 permit ip any any (if i should use this command instead of access-list 100 permit ip any host )
Because if you should use “access-list 100 permit ip any any” … Can you use neq operator, and enter one command instead of two ?
Guys you should download dumps and many other helping materials from
[ a d f . l y / o 7 b a 3 ]
Hello guys, I’m taking CCNA next week. I need the latest dumps, must pass this test. Please send to Lward602@yahoo.com thanks
A passed today with 972 ACL1 ACL2 And EIGRP
Guys, im confused in modification 1.. where IP 172.22.242.16 came from? please answer thank you :)
How can i checked if my configuration is correct? im currently doing modification 1 – 4 thanx
Just visiting back after passing last month. 9tut helped me confirm what I already knew. Probably the two biggest things that helped me pass was the Wendell Odom book and I built my own lab with the suggestions at certificationkits http://www.certificationkits.com/cisco-lab-suggestions/ I also used their lab workbook and it was pretty awesome as it was about 500 pages of labs that took me about 4 weeks to get through them all practicing one to two hours a night. The hands on really helped make the theory real for me. It also helped me get a job as the three people that I had to interview with at the company that hired me were pretty impressed that I had actually experience configuring routers and switches that they use in their company and that I that I was the only person they spoke to that took that initiative and they said it was one of the main reasons they hired me. I can’t wait to learn more on the job! :) I hope that helps and best of luck to everyone.
@amen that ip address is nw id if u want deny the host for al server nw id is used instead of the ip address
172.22.242.16/28 is the nw id
@Ranjith, im confused in modification 1.. where IP 172.22.242.16 came from? please answer thank you :)
@Amen, because the subnet mask of the network 172.22.242.0 is not given but you can see it at “#show running-config” that it is /28 subnet mask for server LAN.
Salam every one.Thanks To Almighty ALLAH today I passed ccna exame and my score is 958.I suggest watson dumps and lab simulation on 9tut.My labs were acl1 same as 9tut,acl2 with mod 3 and eigrp same as 9tut.
PLEASE AFTER CCNA WHICH CCNP I SHOULD GO FOR , CAN SOMEONE ADVICE
ACL, ACL2, EIGRP were all on the test this morning. Passed. Modification 4. PC D instead of C was the pc that need to have access to Finance Server “PC3″
anyone has any luck finding cisco jobs?
I passed my exam today.. labs were ACL1, ACL2 and EIGRP with AS number 12. Dumps were watson and Mathews.
Thanks all