Home > OSPF Neighbor Sim

OSPF Neighbor Sim

October 6th, 2014 Go to comments

Question

Refer to the topology. Your company has decided to connect the main office with three other remote branch offices using point-to-point serial links. You are required to troubleshoot and resolve OSPF neighbor adjacency issues between the main office and the routers located in the remote branch offices.

OSPF_Neighbor_Sim.jpg

Instead of posting the output of “show run” commands we post here the commands entered on each router to reduce some useless lines. Also you can try solving questions by yourself before reading the answers.

R1
interface Loopback0
 description ***Loopback***
 ip address 192.168.1.1 255.255.255.255
 ip ospf 1 area 0
!
interface Ethernet0/0
 description **Connected to R1-LAN**
 ip address 10.10.110.1 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/1
 description **Connected to L2SW**
 ip address 10.10.230.1 255.255.255.0
 ip ospf hello-interval 25
 ip ospf 1 area 0
!
router ospf 1
 log-adjacency-changes

R2
!
interface Loopback0
 description **Loopback**
 ip address 192.168.2.2 255.255.255.255
 ip ospf 2 area 0
!
interface Ethernet0/0
 description **Connected to R2-LAN**
 ip address 10.10.120.1 255.255.255.0
 ip ospf 2 area 0
!
interface Ethernet0/1
 description **Connected to L2SW**
 ip address 10.10.230.2 255.255.255.0
 ip ospf 2 area 0
!
router ospf 2
 log-adjacency-changes
R3
username R6 password CISCO36
!
interface Loopback0
 description **Loopback**
 ip address 192.168.3.3 255.255.255.255
 ip ospf 3 area 0
!
interface Ethernet0/0
 description **Connected to L2SW**
 ip address 10.10.230.3 255.255.255.0
 ip ospf 3 area 0
!
interface Serial1/0
 description **Connected to R4-Branch1 office**
 ip address 10.10.240.1 255.255.255.252
 encapsulation ppp
 ip ospf 3 area 0
!
interface Serial1/1
 description **Connected to R5-Branch2 office**
 ip address 10.10.240.5 255.255.255.252
 encapsulation ppp
 ip ospf hello-interval 50
 ip ospf 3 area 0
!
interface Serial1/2
 description **Connected to R6-Branch3 office**
 ip address 10.10.240.9 255.255.255.252
 encapsulation ppp
 ip ospf 3 area 0
 ppp authentication chap
!
router ospf 3
 router-id 192.168.3.3
!
R4
!
interface Loopback0
 description **Loopback**
 ip address 192.168.4.4 255.255.255.255
 ip ospf 4 area 2
!
interface Ethernet0/0
 ip address 172.16.113.1 255.255.255.0
 ip ospf 4 area 2
!
interface Serial1/0
 description **Connected to R3-Main Branch office**
 ip address 10.10.240.2 255.255.255.252
 encapsulation ppp
 ip ospf 4 area 2
!
router ospf 4
 log-adjacency-changes
R5
!
interface Loopback0
 description **Loopback**
 ip address 192.168.5.5 255.255.255.255
 ip ospf 5 area 0
!
interface Ethernet0/0
 ip address 172.16.114.1 255.255.255.0
 ip ospf 5 area 0
!
interface Serial1/0
 description **Connected to R3-Main Branch office**
 ip address 10.10.240.6 255.255.255.252
 encapsulation ppp
 ip ospf 5 area 0
!
router ospf 5
 log-adjacency-changes
R6
username R3 password CISCO36
!
interface Loopback0
 description **Loopback**
 ip address 192.168.6.6 255.255.255.255
 ip ospf 6 area 0
!
interface Ethernet0/0
 ip address 172.16.115.1 255.255.255.0
 ip ospf 6 area 0
!
interface Serial1/0
 description **Connected to R3-Main Branch office**
 ip address 10.10.240.10 255.255.255.252
 encapsulation ppp
 ip ospf 6 area 0
 ppp authentication chap
!
router ospf 6
 router-id 192.168.3.3
!

Note: Packet Tracer does not support enabling OSPF under interface mode (ip ospf 3 area 0). We don’t know why such a popular command is not supported so we can’t make a pkt file for this lab.

Question 1

An OSPF neighbor adjacency is not formed between R3 in the main office and R4 in the Branch1 office. What is causing the problem?

A. There is an area ID mismatch.
B. There is a Layer 2 issue; an encapsulation mismatch on serial links.
C. There is an OSPF hello and dead interval mismatch.
D. The R3 router ID is configured on R4.

 

Answer: A

Explanation

We learned it is a OSPF problem so we should check the interfaces between them first. On both R3 and R4 use “show running-config” command to check their S1/0 interfaces

R3#show running-config
<<output omitted>>
!
interface Serial1/0
  description **Connected to R4-Branch1 office**
  ip address 10.10.240.1 255.255.255.252
  encapsulation ppp
  ip ospf 3 area 0
!
<<output omitted>>
R4#show running-config
<<output omitted>>
!
interface Serial1/0
  description **Connected to R3-Main Branch office**
  ip address 10.10.240.2 255.255.255.252
  encapsulation ppp
  ip ospf 4 area 2
!
<<output omitted>>

In the output above we see their Area IDs are mismatched; interface S1/0 of R3 is in area 0 (R3: ip ospf 3 area 0) while interface s1/0 of R4 is in area 2 (R4: ip ospf 4 area 2).

Question 2

An OSPF neighbor adjacency is not formed between R3 in the main office and R5 in the Branch2 office. What is causing the problem?

A. There is an area ID mismatch.
B. There is a PPP authentication issue; a password mismatch.
C. There is an OSPF hello and dead interval mismatch.
D. There is a missing network command in the OSPF process on R5.

 

Answer: C

Explanation

Continue checking their connected interfaces with the “show running-config” command:

R3#show running-config
<<output omitted>>
!
interface Serial1/1
  description **Connected to R5-Branch2 office**
  ip address 10.10.240.5 255.255.255.252
  encapsulation ppp
  ip ospf hello-interval 50
  ip ospf 3 area 0
!
<<output omitted>>
R5#show running-config
<<output omitted>>
!
interface Serial1/0
  description **Connected to R3-Main Branch office**
  ip address 10.10.240.6 255.255.255.252
  encapsulation ppp
  ip ospf 5 area 0
!
<<output omitted>>

The only difference we can see here is the line “ip ospf hello-interval 50″ on R3. This command sets the number of seconds R3 waits before sending the next hello packet out this interface. In this case after configuring this command, R3 will send hello packets to R5 every 50 seconds. But the default value of hello-interval is 10 seconds and R5 is using it. Therefore we can think of a hello interval mismatch problem here. You can verify with the “show ip ospf interface <interface>” command on each router.

R3#sh ip ospf int s1/1
Serial1/1 is up, line protocol is up
  Internet Address 10.10.240.5/30, Area 0
  Process ID 3, Router ID 192.168.3.3, Network Type POINT_TO_POINT, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 50, Dead 200, Wait 200, Retransmit 5
  oob-resync timeout 200
  Hello due in 00:00:28
  Supports Link-local Signaling (LLS)
  Index 2/2, flood queue length 0
  Next 0×0(0)/0×0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)
R5#sh ip ospf int s1/0
Serial1/0 is up, line protocol is up
  Internet Address 10.10.240.6/30, Area 0
  Process ID 5, Router ID 10.10.240.6, Network Type POINT_TO_POINT, Cost: 64
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
  oob-resync timeout 40
  Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0×0(0)/0×0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0
  Suppress hello for 0 neighbor(s)

So we can see both hello and dead interval are mismatched because the dead interval always four times the value of hello interval, unless you manually configure the dead interval (with the ip ospf dead-interval <seconds> command).

Question 3

R1 does not form an OSPF neighbor adjacency with R2. Which option would fix the issue?

A. R1 ethernet0/1 is shutdown. Configure no shutdown command.
B. R1 ethernet0/1 configured with a non-default OSPF hello interval of 25; configure no ip ospf hello-interval 25
C. R2 ethernet0/1 and R3 ethernet0/0 are configured with a non-default OSPF hello interval of 25; configure no ip ospf hello-interval 25
D. Enable OSPF for R1 ethernet0/1; configure ip ospf 1 area 0 command under ethernet0/1

Answer: B

Explanation

Continue checking their connected interfaces with the “show running-config” command:

R1#show running-config
<<output omitted>>
!
interface Ethernet0/1
  description **Connected to L2SW**
  ip address 10.10.230.1 255.255.255.0
  ip ospf hello-interval 25
  ip ospf 1 area 0
!
<<output omitted>>
R2#show running-config
<<output omitted>>
!
interface Ethernet0/1
  description **Connected to L2SW**
  ip address 10.10.230.2 255.255.255.0
  ip ospf 2 area 0
!
<<output omitted>>

We see the hello interval on R1 is not the same as R2 (and you can verify with the “show ip ospf interface <interface> command”) -> There is a hello and dead interval mismatch problem. We should configure “no ip ospf hello-interval 25″ on R1.

Note: Maybe there are some versions of this question in the exam. For example there are some reports saying that Ethernet0/1 on R1 is shutdown (and this is the correct choice in the exam). So please be careful checking the config on the routers before choosing the correct answers.

Question 4

An OSPF neighbor adjacency is not formed between R3 in the main office and R6 in the Branch3 office. What is causing the problem?

A. There is an area ID mismatch.
B. There is a PPP authentication issue; the username is not configured on R3 and R6.
C. There is an OSPF hello and dead interval mismatch.
D. The R3 router ID is configured on R6.

 

Answer: D

Explanation

R3#show running-config
<<output omitted>>
username R6 password CISCO36
!
interface Serial1/2
  description **Connected to R6-Branch3 office**
  ip address 10.10.240.9 255.255.255.252
  encapsulation ppp
  ip ospf 3 area 0
  ppp authentication chap
!
<<output omitted>>
!
router ospf 3
  router-id 192.168.3.3
!
<<output omitted>>
R6#show running-config
<<output omitted>>
username R3 password CISCO36
!
interface Serial1/0
  description **Connected to R3-Main Branch office**
  ip address 10.10.240.10 255.255.255.252
  encapsulation ppp
  ip ospf 6 area 0
  ppp authentication chap
!
<<output omitted>>
!
router ospf 6
  router-id 192.168.3.3
!
<<output omitted>>

We are not sure about the configuration of ppp authentication in this case. Some reports said that only one router has the “ppp authentication chap” command but it is just a trick and is not the problem here. The real problem here is R6 uses the same router-id of R3 (192.168.3.3) so OSPF neighborship cannot be established. In real life, such configuration error will be shown in the command line interface (CLI). So please check carefully for this question.

Comments (214) Comments
Comment pages
  1. Farzan
    October 16th, 2014

    Hey i got question..
    in simulations can we use hint ?? Like when you type ” sh ip ospf ? “

  2. Anonymous
    October 16th, 2014

    yes

  3. mahmoodIQ
    October 17th, 2014

    ther is no PKT file to download it

  4. Mostafa
    October 21st, 2014

    can’t find the .pkt file could someone upload it fast plz

  5. amin
    October 21st, 2014

    @ hi 9tut and everyone,
    anyone encounter this lab in latest exams ???

  6. king
    October 23rd, 2014

    pls can you upload the pkt lab here so we can try our hands on.

  7. 9tut
    October 23rd, 2014

    @king: Packet Tracer does not support enabling OSPF under interface mode (ip ospf 1 area 0) command so we cannot create pkt file for this sim.

  8. IDRIS
    October 26th, 2014

    can anyone tell me if this question came out on his or her question during exam?

  9. Cavey
    October 27th, 2014

    Recently took ICND1 about 4 or 5 weeks ago and found this question popped up. :o(

  10. Tiks
    October 31st, 2014

    Send me letest dumbs on tilak2710@yahoo.com

  11. Dimple
    November 2nd, 2014

    Could you pls send me the updated Dumps on dimpleguy00@yahoo.com.

  12. 3Bs
    November 3rd, 2014

    Hi All,

    For question no 6. Do i need to issue “clear ip ospf process” command after changing R6 router id?

    Please help. Thanks. :)

  13. me
    November 4th, 2014

    I think this is a lab where you just answer the questions, no need to change any configs

  14. 3Bs
    November 4th, 2014

    @me: Alright! Thanks! :-)

  15. Ali
    November 4th, 2014

    These are Lab SIMs ?
    or Just Multiple Choice Q/A.

    Waiting for anybody to answer.

    Thanks

  16. tanu
    November 6th, 2014

    if dumps have been changed pls someone send me latest dumps @” debonair.tj@gmail.com ” now
    i have my exam today.

  17. joseph
    November 6th, 2014

    Word going round the questions have changed…in panic mode over here,who has for the exam of late?whats new in there? got my exam in days..anyone with the latest dump?help out a brother over here pliz…..elninotito@gmail.com is my email address

  18. Dan
    November 7th, 2014

    GUYS!!! what is this??? ip ospf x area 0…this command on the interface itself is for ospf v3 that’s IPV6….you have IPV4..is this really in exam??? This is wrong!!! how can they place something like this…I am so confused now..what happened with ”network” command??? 9tut..wtf?

  19. holman
    November 7th, 2014

    Hu Tanu,
    When you finish pls update us as well.

    all the best

  20. isuru
    November 7th, 2014

    Hi everyone
    anyone have this lab in your latest exams ???

  21. sara
    November 7th, 2014

    hi.. send me the latest exam ….
    sara.el.ekhaider.7@gmail.com

  22. Dan
    November 8th, 2014

    Please someone explain why this simulator uses ip ospf x area 0 command to implement ospf on interfaces with IP v4?? I have not seen any documentation that explains this..Normally correct is to use the network command. Please email me a short explanation about ccna material that covers this. if This is in CCNA I am totally screwed! ginaspur@yahoo.com

  23. faqzao
    November 8th, 2014

    @Dan: your observation is valid. “ospf X area Y” is for IPv6. But remember you can have both IPv4 and IPv6 at the same time on the interfaces, thus you may still see such config. At least, this is what I learned from reading the books. Will take the in a few hours from now, and surely will report.

  24. Dan
    November 8th, 2014

    @faqzao please report if you encounter this specific configuration for ipv4 interfaces in the exam. I have never used this for IPV4, or ever seen it except here on 9tut. maybe it’s some kind of similarity with the OSPFv3 ipv4 AF( Address Family) but the commands are not quite like that…So I still think the configurations represented here on 9tut are wrong!!! How can we contact the 9tut administrator???
    this is clear OSPF V2:
    router ospf 1
    log-adjacency-changes….I see no IPV6…so?

  25. Ahmed
    November 8th, 2014

    @Dan im so panic when i c ospf 1 area 0 u right we i never seen these config on CCNA …..

  26. newAssociate
    November 9th, 2014

    @Dan: according to the link below, this is not wrong. Anyways, score 100% yesterday, and this question didn’t show up. Had ACL1, ACL2, and EIGRP all with modifications. Best of luck.
    http://www.cisco.com/c/en/us/td/docs/ios/12_0s/feature/guide/ospfarea.html

  27. darsh
    November 9th, 2014

    hi friends . pay attention plz . i passed today . score 1000/1000
    simulation acl 2 , eigrp
    all questions from watson exam and 9tut
    thanx watson . many thanx 9tut
    good luck for u all

  28. darsh
    November 9th, 2014

    also tab and ? are working

  29. Fady S
    November 9th, 2014

    Passed exam on 22nd Oct, 2014

    Almost all questions from Watson dump, labs are ACL1,2 & EIGRP in 9tut.
    One new question about etherchannel, it’s easy. Good luck.
    “?” is working in exam, Thank you.

  30. Dan
    November 9th, 2014

    the comand ip ospf x area y in interface configuration mode is indeed ducumented in the link provided above…but I am sure this is above ccna level!!! Still a bitch move by cisco if the get this in the exam!

  31. kylie
    November 11th, 2014

    @fady s: configuring etherchannel is in the exam?

  32. dan is right
    November 13th, 2014

    if ip addresses on the table are ipv4 y is there a config for ospfv3?

  33. Dario
    November 13th, 2014

    Hi
    How many Labs there are in a exam =?

    Thanks

  34. Bakin’ my Ham
    November 13th, 2014

    I have several different Packet Tracer Activities (.pka) that will let you practice:

    Setting up basic OSPFv2 configurations
    Setting up advanced OSPFv2 configurations
    Setting up basic OSPFv3 configurations
    Troubleshoot OSPFv2 adjacency problems

    These are .pka files, which means you are guided thru the steps and as you correctly configure devices, you gain points. You can check your results as you go along, and see what’s not configured correctly. A timer shows how long you’re taking, but you can take as long as you want.

    These are the latest PT Activities from the new academy curriculum.

    I need the Watson and Matthew dumps (or others?). I assume they work on Visual Certexam?

    I can trade…

  35. Dario
    November 14th, 2014

    Hi Bakin
    Can you send my file.pka ? d.mazzi77@gmail.com
    I have vce file and pdf file.

    Thanks

  36. sichi
    November 14th, 2014

    can you also give me a pkt file for this?
    michaelsichico@gmail.com

  37. Bakin’ my Ham
    November 14th, 2014

    @Dario
    I sent you a few .pka files…
    Please let me know if they help you.

    Please send the Watson and Matthew files… I’m testing in ONE week!!
    Argh!!!!!!! :D

  38. Xavie
    November 16th, 2014

    Dear all
    Please help me of this exam..i can do tomorrow pls give me latest dumps and latest lab exam..my email id dimpleguy00@yahoo.com

  39. richard
    November 16th, 2014

    For this question, I am not understand why using (ospf “no”) for each router?
    Are they from Router 1 to Router 6 using the same topology ?
    why not use ip ospf 1 area 0 for all the command statement??

    Thanks!!!

  40. richard
    November 16th, 2014

    Pls give me latest dumps and latest lab exam, my email upd79@yahoo.com.hk

  41. Tikka
    November 17th, 2014

    I am planing to do my CCNA exam on 24th November. Can anyone send me the latest dumps plz. Here is my email- tik.kira@yahoo.com . Thanks.

  42. Dario
    November 17th, 2014

    I’m sorry Bakin I see your message now.
    as’ gone exam ?

  43. M Umar
    November 18th, 2014

    I plan to attempt CCNA exam in December. Can anyone send me the latest dumps plz. Here is my email- mian.umar28@gmail.com . Thanks.

  44. reji
    November 20th, 2014

    guys tell me whether ” tab & shift+? ” works in exam?

  45. richard
    November 20th, 2014

    Can any one explain to me?

    I don’t understand why using [ospf “no”] for each router?

    e.g.
    In router 3,

    router ospf 3
    router-id 192.168.3.3

    In router 6,

    router ospf 6
    router-id 192.168.3.3

  46. richard
    November 20th, 2014

    Can any one explain to me?
    I don’t understand why using the same [ospf “no”] for each router?

    e.g.
    In router 3,
    router ospf 3
    router-id 192.168.3.3

    In router 6,
    router ospf 6
    router-id 192.168.3.3

    So that this network would have OSPF1, 2, 3, 4, 5, 6 running at the same network for the same group routers at the same time ?

  47. segun
    November 21st, 2014

    @ richard, the number refers to the ospf process-id which is used in identifying a single instance of ospf running on a router. In essence, it is locally significant and there can be more than one ospf process running on a single router.

    I hope that answers your question.

    BR

  48. Omz
    November 23rd, 2014

    Hi all
    Is it possible for someone to send me the dumps for CCNA? Exam next week any help highly appreciated! Thanks

  49. Omz
    November 23rd, 2014

    Oppps … omc79 at hotmail dot com

  50. lonn
    November 24th, 2014

    no .pka to download of this section ?

Comment pages
Add a Comment