CCNA EIGRP LAB Question
Question
After adding R3 router, no routing updates are being exchanged between R3 and the new location. All other inter connectivity and Internet access for the existing locations of the company are working properly.
The task is to identify the fault(s) and correct the router configuration to provide full connectivity between the routers.
Access to the router CLI can be gained by clicking on the appropriate host. All passwords on all routers are cisco.
IP addresses are listed in the chart below.
R1 Fa0/0: 192.168.77.33 S1/0: 198.0.18.6 S0/1: 192.168.60.25 S0/0: 192.168.36.13 |
R2 Fa0/0: 192.168.60.97 Fa0/1: 192.168.60.113 S0/0: 192.168.36.14 |
R3 Fa0/0: 192.168.77.34 Fa0/1: 192.168.60.65 Fa1/0: 192.168.60.81 |
R4 Fa0/0: 192.168.60.129 Fa0/1: 192.168.60.145 S0/1: 192.168.60.26 |
Answer and explanation
(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://www.9tut.com/eigrp-routing-protocol-tutorial. Note: You can download this sim to practice here: http://www.9tut.com/download/9tut.com_CCNA_EIGRP_sim_question.zip)
We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of R3 router, enter the show running-config command
From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.
(You should check the AS numbers on other routers for sure)
To solve this problem, we simply re-configure router R3 with the following commands:
R3>enable (you have to enter cisco as its password here)
R3#configure terminal
R3(config)#no router eigrp 22
R3(config)#router eigrp 212
R3(config-router)#network 192.168.60.0
R3(config-router)#network 192.168.77.0
R3(config-router)#no auto-summary
R3(config-router)#end
R3#copy running-config startup-config
Check R1 router with the show running-config command:
Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize R3 router
R1>enable (you have to enter cisco as its password here)
R1#configure terminal
R1(config)#router eigrp 212
R1(config-router)#network 192.168.77.0
R1(config-router)#end
R1#copy running-config startup-config
Now the whole network will work well. You should check again with ping command from router R3 to other routers!
Modifications:
Maybe in this EIGRP Sim you will see the “passive-interface …” command somewhere in R1 configuration. If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this:
R1:
!
router eigrp 212
passive-interface s1/0
!
then we just leave it. Don’t use the “no passive-interface s1/0″ on R1 because the link between R1 & ISP doesn’t need EIGRP to run on it. A static route from R1 to ISP & “ip default-network” command in R1 are correct so that all the routers (R1, R2, R3, R4) can access the Internet.
(Note: The “ip default-network” command in R1 will advertise the static route of R1 (to go to the Internet) to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines in R1 configuration:
!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!
If you want to learn more about “ip default-network” command please read: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml
I read recent comments and realized that you will see the “passive-interface” in the link between R1 & ISP router so just leave it.
Note: Also some readers confuse about if we should use the wildcard masks on the “network” statements under EIGRP process or not. For example should we use:
router eigrp 212
network 192.168.77.0 0.0.0.3
The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not make the routes conflicting. The “network …” command in EIGRP (and OSPF, RIP) does not means “advertise this network” but means “If I has interface(s) belongs to this network please turn on EIGRP on that interface. Therefore when you don’t use wildcard mask EIGRP will turn on EIGRP on all interfaces that belongs to the network you specify in the “network …” command.
You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same major networks but you don’t want to run EIGRP on all of them. For example if your router has 2 interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP on the first interface, you can type “network 192.168.30.0 0.0.0.15″ under EIGRP process.
Other lab-sims on this site:
CCNA Configuration SIM Question (RIPv2 SIM)
Hi everybody, After finishing the SIM on Packet Tracer I tried to ping R1 from Hosts C and D but “request time out”.
Can you help me why ?
And please I’d like to ask why we don’t type no auto-summary command on R1 after adding the missing network(R3) ?
@ Ayman no auto-summary already on R1 no need to type again.
@ Ayman How did you initiate the ping? Use the Privilege mode to do ping. R3#ping 192.168.60.97 will ping to R2. Then pick IPs for R1 and R4 and see if those work too. Let me know how you did.
Same as Mavura can not do EIGRP simulation because can not telnet to other routers. Have to be done with ssh? Please help.
I passed the exam with 947/1000. Thanks to 9tut model Qs and labs, and dumps and for my friend for introducing this site for me. Had a new question for IPsec data integrity.
ANSs were keyed-hash message authentication code (HMAC)
HMAC – MD5 and HMAC – SHA1
can I use on R3 the following config:
R3#configure terminal
R3(config)#no router eigrp 22
R3(config)#router eigrp 212
R3(config-router)#network 192.168.60.64
R3(config-router)#network 192.168.60.80
R3(config-router)#network 192.168.77.32
R3(config-router)#no auto-summary
R3(config-router)#end
R3#copy running-config startup-config
and on R1:
R1#configure terminal
R1(config)#router eigrp 212
R1(config-router)#network 192.168.77.32
R1(config-router)#end
R1#copy running-config startup-config
I have just learnt CCNA. I have a question need everybody to help answer:
I have download some dumps from examcollections.com. If I want to pass CCNA 640-802 exam, I need to learn all questions in these dumps, don’t I ?
Please to answer me! Thank you !
@ Diego
according to me ( Correct me if i am wrong )
If u use that setting on R3 using 192.168.60.64 instead of 192.168.60.0 Then only tht .64 port will run EIGRP. Router only allow tht port to be routing.. not any host under that network which is connected to under that router which is incorrect routing if u cnt reach host under tht router.. so better give network address for routing instead of giving particular port address. :)
@ Deigo you need to use the NETWORK ADDRESS not just the IP. Shubbam is correct. So combine your two IPs ( 192.168.60.64 & 192.168.60.80 ) to get the network address 192.168.60.0.
@ Diego Forgot to mention – in R1 replace 192.168.77.32 with 192.168.77.0
@john:
yes and also learn the concepts as well.
pls confirm!.i just heard ccna 200 120 was reviewed today.
and i was abt writting the exam tomorrow.
@ obiinna Sorry but most of us are doing 640-802 right now. Hope you get a response But why would they review it when they just introduced it?
big big big thanks to 9tut, great job! For EIGRP I had another unused network added, but it didn’t install in route table since nothing was connected to it, just leave it. Study all lab questions and you will pass for sure.
http://www.9tut.com/download/9tut.com_CCNA_EIGRP_sim_question.zip) doesn’t work on packet tracer 5.1 ANY HELP !!
passive interface…as number ….network addresses….is that all to check in this kind of a lab?
if there is something more than that please let me know….
in vtp if the sw ac3 and the swx revison number are same….wat will happen…?and wat kind of a answer is correct….?please let me know….
Thanks for your help I´m really grateful, I´m from Costa Rica, pura vida a todos…! One more question, what’s better p4sure or visual cert ?
I cannot ping all routers. I was only able to ping 192.168.77.33. So what you think is missing? This tutorial said I should be able to ping all routers.
Can anyone respond to one of the questions in EIGRP SIM: If we configured ip default-network 198.0.18.0 and ip route 0.0.0.0 0.0.0.0 198.0.18.5 on R1 why is it not propagated to other routers? I know if I use redistribute static I can propagate it to other routers but not for default-network…………..Help me out on this b/s I had this question in the last ccna exam and it didn’t allow me to use redistribute static and I should know the other working alternative.
download latest dumps from
9 t u t . w e e b l y . c o m
I WILL TAKE THE EXAM TMRW I HOPE AM SUCCESFULY PASS THE EXAM KIDANEMIRT DO NOT FORGET ME
@ B/Gen.
Did u add no auto-summary command on R3? if yes then for sure u fgt to save config by “copy running-config startup-config” on R3 and R1 after editing…
@CiscoER:
In the real exam, after changing the AS number on R3 and after adding the network to R3 in EIGRP on R1, ping is working. I don’t remember if I tried all destinations. I just tried at least two of the destinations that were not responding to ping before.
@tega:
I just used the dumps on examcollection.com (the one from August by ACME) and the labs you find here on 9tut.com. Nothing else.
Do you get a different lab sim on your second attempt? I heard when you retake, they replace one of the labs with NAT lab. Can anyone one confirm this?
Boa tarde galera. Ontem fiz meu exame number: 640-802, You Score: 933/1000, Grade: Pass.. Agradeço a muito a Deus. Dump do Spike e Acme 100% valido obrigado. Labs 9tut foram (Eigrp, Acl, Vtp). Boa sorte !!!
I’ve passed today!….Be aware of this!
Don’t try to configure eigrp neworks with wildcard mask, even if the sub-networks overlap!! The exam software is not so good and it will not consider your statements. I tried in so many ways and did not succeed with wildcard mask.
Many thanks 9tut! :)
Failed on Sunday. Was wondering if anyone else experienced issues with the lab SIM when trying to input commands, special characters were coming up as I was typing which caused me to have to correct my configs after typing. This took alot of time which took away time from answering remaining questions. Also when I re-take the exam, will there be different Lab Sims or will I get the same ones? Thanks in advance for any help
I passed my exam today with 960. Sims were VTP, ACL2, and EIGRP. No need to use wildcard mask . With the no auto-summary command you are telling the router to consider the subnets. On EIGRP lab I noticed on R1 that eigrp 212 had a network that was no needed. Let’s say it was network 192.168.79.0 , so I took that away with the no network command an put the right one (192.68.77.0 as the example above ). You can just put 192.168.77.0 and leave the other one too, It doesn’t change the configuration but maybe that give me extra points. How do I know if my sims were ok? anyone knows?
I had an issue with VTP SIM, When executing show spanning-tree vlan 1 command (to see who’s the root bridge for vlan 1) I could only see two ports and both on designated mode, so knowing the theory you may think , hey this is the root bridge!. But nooo, if you look carefully that command also shows you the root bridge with a different mac address. So i dont know if they did it on purpose but if you do “show spanning-tree ” without specifying the vlan number. You’ll get to see vlan1 with tree ports , the 2 designated ports and also one port (f0/12 on my case) as root proofing that this switch was not the root bridge.
@Happy are you saying you cannot enter the following command if it’s not listed on R1:
ip route 0.0.0.0 0.0.0.0 198.0.18.5
what command would you enter instead if it wont let you enter the wild card mask?
hhmmmm crucial moment to pass but awesome !!! i pass the exam
thanks for the Following
9tut.com – your the best
testking reviewer
jeremy video lab
dancourse.com video lab
and etc..
Can you help me please??
I want to remove “passive-interface Serial0/0”
when I enter the “show running-config” command on router R1 and output show:
router eigrp 23
passive-interface Serial0/0
network 192.168.36.0
network 198.0.18.0
network 192.168.90.0
network 192.168.50.0
mark: Serial0/0 is the link between R1 & ISP and IP address is 192.0.18.5
thankyou very much
You don’t have to remove that, it’s not blocking traffic .It’s there because You don’t need to send eigrp updates through that serial interface . If you want to know how to do it just go to configure mode , execute router eigrp 23 then no passive-interface s0/0
@Enz
I wasn’t talking about the default-route. In this case the syntax is ok, and it does’t need wildcard mask, it uses network mask.
The problem was when I tried to configure network statements with wildcard mask in (config-router)# on R3 (the new router).
Good luck!
My friend get this lab yesterday, and he said he has 2!!! fa0/0 interface. He couldn’t solve the bug….
Somebody see this problem before in real exam?
Can i configure on router 1 like this
Router eigrp 212
Network 192.168.77.32
I think you *don’t* remove the passive interface on s1/0 because that is the link to ISP. However, you *do* remove the passive-interface on s0/0 if listed or on the other interfaces except s1/0 (correct me if I am wrong)
Help Me pls…
If the there is a passive int/fa cmd in R1 to ISP ..we wont remove it…AFTER THAT
If the there is a passive int/fa cmd R1 to ISP ,we wont remove it.
after THAT what should i do ?
should i give Ip default network cmd & static route cmd ? is that correct ?
@ SBN
Its Okay
No pblm at all
@happy
cheers for that i know what you mean now
Passed my CCNA exam today afternoon with score 947… Thanks 9tut… all Sims from 9tut .. ACL,Eigrp,NAT… Jsut IP and AS number was chnaged
Hi Everyone!!
Needs your help please! I took my exam a month ago and failed. I had issue with the access-list lab, I had this one: Host B should be able to use a web browser(HTTP) to access the Finance Web server. Other types of access from host B to the finance Web server should be blocked. All access from hosts………should be blocked. Hosts in the core and local LAN should be able to access the public web Server. This were the commands i did for the access-list:
Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.63.17 eq 80
corp1(config)#access-list 100 permit ip any host 172.22.63.18
corp1(config)#access-list 100 deny ip any any
corp1(config)#interface fastethernet0/1
corp1(config)#ip access-group 100 out
So, by opening the web browser of host B and entering the Finance ip address it was fine but why host D, A, and C will have also access to the Finance web server? It was hard to figure out, Pls somebody can help and tel me what should have done to make it work. Thanks,
the “?” key works in acl2 sim in exam ? please someone reply
hi fox
about what you have given
***Host B should be able to use a web browser(HTTP) to access the Finance Web server.
This command will allow host B to browes the Finance Web server.
Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.63.17 eq 80
***Other types of access from host B to the finance Web server should be blocked. All access from hosts………should be blocked.
This command will prevent host B & other hosts to access or ping the finance web server
Corp1(config)#access-list 100 deny ip any host 172.22.63.17
***Hosts in the core and local LAN should be able to access the public web Server.
This command will allow all hosts to access the pubic web server
corp1(config)#access-list 100 permit ip any host (public web Server ip)
corp1(config)#interface fastethernet0/1
corp1(config)#ip access-group 100 out
i do not know if its correct or not,i have practised it on the packet tracer and i got the correct result
if iam wrong please correct my answer
thanks in advance
i passed my ccna exam today and got 867,, lap was acl with some modicication,,eigrp,, vtp,,,
bt i got some trick in vtp.. When i did show vtp status there is no ip in the end of output,,so i choose switch-ac3(local), and also acl was ,,access-list 100 permit tcp host 192.168.186.3 host 172.22.234.23 eq www
access-list 100 deny ip host 192.168.186.3 host 172.22.234.23
access-list 100 deny ip any host 172.22.234.23
access-list 100 permit ip any any
also i found in eigrp the passive-interface s0/1 i guess,, but this interface with ISP so i let it like this.. Be careful guys and good luck alll .,thanks all who help me here and examcollection,, good luck all
i was expected more than 900 but alhmdulillah in any way..helpful dumz are acme in examcollection and karvin.. Also ip addressing and how networks work is too much…take care,,glad to help anyone :)
also thanks to jermey cbt nuggets :)