Home > CCNA Access List Sim 2

CCNA Access List Sim 2

February 15th, 2014 Go to comments

Question

A network associate is adding security to the configuration of the Corp1 router. The user on host C should be able to use a web browser to access financial information from the Finance Web Server. No other hosts from the LAN nor the Core should be able to use a web browser to access this server. Since there are multiple resources for the corporation at this location including other resources on the Finance Web Server, all other traffic should be allowed.

The task is to create and apply a numbered access-list with no more than three statements that will allow ONLY host C web access to the Finance Web Server. No other hosts will have web access to the Finance Web Server. All other traffic is permitted.
Access to the router CLI can be gained by clicking on the appropriate host.

All passwords have been temporarily set to “cisco”.
The Core connection uses an IP address of 198.18.196.65
The computers in the Hosts LAN have been assigned addresses of 192.168.33.1 – 192.168.33.254
Host A 192.168.33.1
Host B 192.168.33.2
Host C 192.168.33.3
Host D 192.168.33.4
The servers in the Server LAN have been assigned addresses of 172.22.242.17 – 172.22.242.30
The Finance Web Server is assigned an IP address of 172.22.242.23.
The Public Web Server is assigned an IP address of 172.22.242.17

access_list_sim2.jpg

Answer and Explanation

(Note: If you are not sure how to use access-list, please check out my access-list tutorial at: http://www.9tut.com/access-list-tutorial, also some modifications about the access-list have been reported so you should read the “Some modifications” section at the end of this question to understand more. You can also download this sim to practice (open with Packet Tracer) here: http://www.9tut.com/download/9tut.com_Access-list_sim2.pkt

Corp1>enable (you may enter “cisco” as it passwords here)

We should create an access-list and apply it to the interface which is connected to the Server LAN because it can filter out traffic from both Sw-2 and Core networks. The Server LAN network has been assigned addresses of 172.22.242.17 – 172.22.242.30 so we can guess the interface connected to them has an IP address of 172.22.242.30 (.30 is the number shown in the figure). Use the “show running-config” command to check which interface has the IP address of 172.22.242.30.

Corp1#show running-config

access_list_sim_show_running.jpg

We learn that interface FastEthernet0/1 is the interface connected to Server LAN network. It is the interface we will apply our access-list (for outbound direction).

Corp1#configure terminal

Our access-list needs to allow host C – 192.168.33.3 to the Finance Web Server 172.22.242.23 via web (port 80)

Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80

Deny other hosts access to the Finance Web Server via web

Corp1(config)#access-list 100 deny tcp any host 172.22.242.23 eq 80

All other traffic is permitted

Corp1(config)#access-list 100 permit ip any any

Apply this access-list to Fa0/1 interface (outbound direction)

Corp1(config)#interface fa0/1
Corp1(config-if)#ip access-group 100 out

Notice: We have to apply the access-list to Fa0/1 interface (not Fa0/0 interface) so that the access-list can filter traffic coming from both the LAN and the Core networks. If we apply access list to the inbound interface we can only filter traffic from the LAN network.

In the real exam, just click on host C and open its web browser. In the address box type http://172.22.242.23 to check if you are allowed to access Finance Web Server or not. If your configuration is correct then you can access it.

Click on other hosts (A, B and D) and check to make sure you can’t access Finance Web Server from these hosts.

Finally, save the configuration

Corp1(config-if)#end
Corp1#copy running-config startup-config

(This configuration only prevents hosts from accessing Finance Web Server via web but if this server supports other traffic – like FTP, SMTP… then other hosts can access it, too.)

Notice: In the real exam, you might be asked to allow other host (A, B or D) to access the Finance Web Server so please read the requirement carefully.

Some modifications:

Modification 1:

permit host B from accessing finance server access-list 100 permit ip host 192.168.33.2 host 172.22.242.23
deny host B from accessing other servers (not the whole network) access-list 100 deny ip host 192.168.33.2 172.22.242.16 0.0.0.15
permit everything else access-list 100 permit ip any any

Modification 2:

Only allow Host C to to access the financial server access-list 100 permit ip host 192.168.33.3 host 172.22.242.23
Not allow anyone else in any way communicate with the financial server access-list 100 deny ip any host 172.22.242.23
Allow all other traffic access-list 100 permit ip any any

Modification 3:

- Host C should be able to use a web browser(HTTP)to access the Finance Web Server access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
- Other types of access from host C to the Finance Web Server should be blocked
- All access from hosts in the Core or local LAN to the Finance Web Server should be blocked
access-list 100 deny ip any host 172.22.242.23
(because the requirement says we can not use more than 3 statements so we have to use “any” here for the hosts in the Core and hosts in local LAN)
- All hosts in the Core and local LAN should be able to access the Public Web Server * access-list 100 permit ip any host
(If the question asks this, surely it has to give you the IP of Public Web Server) but in the exam you should use “access-list 100 permit ip any any”

Modification 4:

Host C should be able to use a web browser to access the financial web server access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
Other types of access from host C to the finance web server should be blocked access-list 100 deny ip host 192.168.33.3 host 172.22.242.23
All hosts in the core and on the local LAN should be able to access the Public web server * access-list 100 permit ip any host
(The IP of Public Web Server will surely be given in this question) but in the exam you should use “access-list 100 permit ip any any”

* There are some reports about the command of “All hosts in the core and on the local LAN should be able to access the Public web server” saying that the correct command should be “access-list 100 permit ip any any”, not “access-list 100 permit ip any host (IP of Public Web Server)”. Although I believe the second command is better but maybe you should use the first command “access-list 100 permit ip any any” instead as some reports said they got 100% when using this command (even if the question gives you the IP address of Public Web Server). It is a bug in this sim.

(Note: Don’t forget to apply this access list to the suitable interface or you will lose points
interface fa0/1
ip access-group 100 out

And in the exam, they may slightly change the requirements, for example host A, host B instead of host C… so make sure you read the requirement carefully and use the access-list correctly)

I created this sim in Packet Tracer v5.2.1 so you can practice with it. You will need new version of Packet Tracer to open it (v5.1+).

accesslist_sim2_packet_tracer.jpg

Download this sim here

Notice: After typing the commands above, if you make a “ping” from other hosts (PC0, PC1, PC3) then PC4 (Finance Web Server) can still reply because we just filter HTTP traffic, not ICMP traffic. To generate HTTP traffic, select “Web Browser” in the “Desktop” tab of these PCs. When a web browser opens, type the IP address of Finance Web Server and you can see how traffic flows in Simulation Mode.

accesslist2_test_http.jpg

And notice that in the initial configuration of this sim the Core network can ping Finance Web Server. We have to create an access-list that can filter this traffic too.

Other lab-sims on this site:

CCNA NAT SIM Question 1

CCNA NAT SIM Question 2

CCNA Frame Relay Sim

CCNA Configuration SIM Question (RIPv2 SIM)

CCNA VTP SIM

CCNA EIGRP LAB

CCNA Drag and Drop SIM

CCNA Implementation SIM

Comments
Comment pages
1 17 18 19 20 21 63 41
  1. Zahid Ismail
    May 5th, 2013

    Passed today 933/1000 , thanks to all mighty Allah
    same EIGRP lab from 9tut,,

    -Host D should be able to use a web browser(HTTP)to access the Finance Web Server
    - Other types of access from host D to the Finance Web Server should be blocked
    – All access from hosts in the Core or local LAN to the Finance Web Server should be blocked
    - All hosts in the Core and local LAN should be able to access the Public Web Server *

    9tut is right dont use ip address of public server in third statement , us MUST use “access-list 100 permit ip any any” this will give you 100% marks..

  2. Jayson
    May 7th, 2013

    Quick question all. If the question is,

    -allow host c web access to finance server

    Will I apply this, access-list 100 permit ip host 192.168.33.2 host 172.22.242.23 or this, access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80

    ??

  3. Fermin Wechsler
    May 8th, 2013

    I got my first smartphone last year from here. I was very very lucky :)

  4. Sick7six
    May 8th, 2013

    I would think since its specifying “Web access” you would need to use
    access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80

  5. ad malik
    May 9th, 2013

    am taking the CCNA exam after 8 days can any body please send me the valid dumps in hmada-9@hotmail.com

  6. Duuly
    May 9th, 2013

    can any body please send me the valid dumps in hemjayzz@yahoo.com

  7. Jayson
    May 10th, 2013

    Thanks Sick7six.

  8. zics
    May 10th, 2013

    Thankx to every1. u guys rock ….

  9. Anonymous
    May 11th, 2013

    (Bogdan wrote: but when typing “sh vtp status” I didn’t see the last line saying “Configuration last modified by” or anything similar.)

    If this happens to anyone else, hit the enter until the last line shows up. This is a known flaw in the VTP Lab.

  10. broccolie
    May 11th, 2013

    Hi everybody,

    First of all thanks for all these examples and explanations.Can we finish the last line of the 3rd example in the “some modifications” part with the command of “access-list 100 permit ip any host 172.22.242.17″?

  11. Baks
    May 11th, 2013

    Alhamdullillah i passed today with 907. Thanks to 9tut.com

  12. benj lopez
    May 13th, 2013

    baks what came out in acl sim i’ll be taking my exam next week
    and eigrp

  13. ruchi
    May 14th, 2013

    hi frnds going to take exam in 1 week plz send me latest dumps with vce new versions @ruchibk043@gmail.com plz… thanks in advance

  14. TekkenLord
    May 14th, 2013

    Plz don’t ask for ppl’s dumps, you can use your own dumps anytime you want…

  15. Omar
    May 15th, 2013

    Sad ! i Failed yesterday 656. I’ll try again .

  16. TON
    May 15th, 2013

    you dont need the dumps…. what youe see here in 9tut is the exact sims in the exam..

  17. Anonymous
    May 16th, 2013

    i can’t open the packet tracer labs …it says invalid

  18. Ptr
    May 16th, 2013

    Guys,took my exam today, 1000/1000.It’s very simple,questions from spike dump 100%.
    For the labs,it’s EIGRP, VTP and ACL2. EIGRP was exactly as the 9tut only the AS number changed to 23 and the was a network in the central router which needed to be removed, the interface to the internet has the passive command and that need not to be removed.dont forget the “no auto-summary” command.
    For the ACL2, only the IPs changed;you were to allow host c to access the finance server via web and block all other forms of access including the lan.
    For VTP, it was exactly as 9tut with no changes.

  19. sam
    May 17th, 2013

    @ which network you have to remove at the central router when you see it. please reply me writing tomorrow.thanx

  20. sam
    May 17th, 2013

    @Ptr which network you have to remove at the central router when you see it. please reply me writing tomorrow.thanx

  21. hello
    May 17th, 2013

    hello . everbody mu name is awais mughal i am ccna and ccnp engring in lahore

  22. Ptr
    May 17th, 2013

    @Sam, it depends whether the network is advertised on the router.all u nid to do is confirm which networks are connected to the interface,those are exactly the networks which need to be advertised. i.e nework x.x.x.x
    Any strange ip which is not in the diagram(exhibit) should not be advertised.
    All the best man.

  23. satheesh
    May 19th, 2013

    i passed CCNA exam with 984/1000 …….thx todd,odom,aravind jha…….nxt my target is ccnp

  24. LR713
    May 19th, 2013

    Passed yesterday. 945/1000. EIGRP, ACL2 Sample modification: 2nd one.

    Used ip any any for last statement.

    Did not get a VTP lab, but did seem to have a good amount of switch questions.

    Thanks!

  25. kk
    May 20th, 2013

    iam writing ccna next week- im still preparing. please send me latest sakhar dumps in pdf.

    email coodsie@yahoo.com

    or vce with crack thank u

  26. salvatore
    May 20th, 2013

    Anyone who took the ccna exam recently? I want to know which simulation came out.

  27. LR713
    May 20th, 2013

    @KK, VCE software cost only about $25. Just buy the software and search for VCE files you need if nobody responds.

    I had EIGRP, ACL1, & ACL2.

    I was looking for VTP on the exam, but did not get it, had ACL1 instead, but it did not call for any configuring, just answering multiple choice type questions.

    Good luck on your exam!

  28. kemdy
    May 20th, 2013

    pls will be writing ccna exams next week pls i will need some dumps, if any pls semd to email ozon3cal@yahoo.com

  29. oscarj
    May 20th, 2013

    you must write like this:

    !
    interface FastEthernet0/0
    ip address 192.168.33.254 255.255.255.0
    ip access-group 100 in
    duplex auto
    speed auto
    !

    Extended access list must be configured as near as posible from source.

  30. sam
    May 20th, 2013

    pass on 17 / 05 /2013 thanks to Almighty God

  31. GREEN
    May 21st, 2013

    HEY LR713 how did it appear lyk in the exam for ACL 1 Question

  32. David Okeri
    May 22nd, 2013

    Pls will be writing ccna exams next month and i will need some dumps, if any with latest dumps pls send to me throw email: olesimbe@yahoo.com

  33. ren
    May 22nd, 2013

    can you provide me the spike dump, pls. thanks…wmsilva@gmail.com

  34. ren
    May 22nd, 2013

    Can someone share a virt cert manager that is not trial version, pls? wmsilva@gmail.com

  35. Michael V
    May 22nd, 2013

    Hello,

    very nice, helpfull and good explained simlet along with its pkt lab. The only thing that I cannot really get is the in and out terms on the interfaces.

    It confuses me always.

    Nice job

    Thanks

  36. Bruke
    May 23rd, 2013

    can any body pass ccna by just preparing 9tut mcqs??

  37. Samrat Bose
    May 24th, 2013

    Hii everybody,
    I cracked CCNA today with 947/1000 as passing score. This was the one of the simulators came today. Thanks a lott to 9tut, this is a very very essential website for CCNA practice.
    God bless !!

  38. Anonymous
    May 25th, 2013

    thank you 9tut….!

  39. Anon
    May 25th, 2013

    Shouldn’t the Ext ACL should be placed as mentioned by Oscarj

    you must write like this:

    !
    interface FastEthernet0/0
    ip address 192.168.33.254 255.255.255.0
    ip access-group 100 in
    duplex auto
    speed auto
    !

    Extended access list must be configured as near as posible from source.

  40. Raazz
    May 25th, 2013

    Hello friends,

    I have scheduled exam on 28th May. if you have latest dumps then please send me @ adhiraaj.np@gmail.com as soon as possible. i would be grateful..

  41. Anonymous
    May 25th, 2013

    oscar j and anon,

    You have to enable the ACL outbound on fa0/1 because you need to ensure the core network gets checked by the list as well. If you enable it inbound on fa0/0 you only are applying the list to that one network and the core network has full access to the servers. It says that right in the answer and explanation above

  42. oscarj
    May 26th, 2013

    A sim like this was un My exam today!

  43. oscarj
    May 26th, 2013

    Thks Anonymous. You are righ!

  44. Armineh
    May 27th, 2013

    Thanks a lot for useful labs …really

  45. Armineh
    May 27th, 2013

    Dearest friends if you have any labs it will be very nice of you to mail me or guide me ,next week I have exam ,pleassse….my mail:armineh.saeedi@gmail.com

  46. Ken
    May 27th, 2013

    Hello Everyone,

    I am scheduled to take my exame on June 7th if any if anyone has the latest dump or anything that will help me as I am struggling with the simlets please email me @ krmoore6351@msn.com….many thanks to you and this 9tut community

  47. Mark
    May 27th, 2013

    Guys, can you please enlighten me on which protocol to use? When dow we use IP, TCP, UDP and ICMP on an ACL? Thanks in advance!

  48. Hi All
    May 28th, 2013

    I plan to take the CCNA 640 802 in July 2013. please could you guys forward the latest dumps… please trying to get CCNA for the past three years now (jmaneveldt@gmail.com).

  49. Mohamed Magdy Fadel
    May 29th, 2013

    First i would to thank my god, then thanks for my CISCO academy, thanks for 9tut, thanks for sekhar, for spike, for brar, thanks for you guys, and thanks for every one who help me :)
    .
    .
    I passed today the CCNA 640-802 exam with score 1000 :)
    .
    .
    All questions from the dumps while sekhar, spike and prepking are all 100% valid and ACL2, VTP and EIGRP sim.s are on my exam.
    And be noted that: In ACL2 sim. the command of “All hosts in the core and on the local LAN should be able to access the Public web server” should be “access-list 100 permit ip any any”, not “access-list 100 permit ip any host (IP of Public Web Server) even if the question gives you the IP address of Public Web Server. It is a bug in this sim.
    .
    .
    And my advice to you is to practice at least two dumps before the exam as it covers all questions which you will face in your exam and make you discover all incorrect answers any the dumps.
    .
    .
    and for any inquiry you can contact me on mounircky@hotmail.com or on mobile +201007978709

  50. ME
    May 29th, 2013

    Thanks God!!!!!!!!!!!

Comment pages
1 17 18 19 20 21 63 41
  1. No trackbacks yet.
Add a Comment