Home > CCNA Access List Sim 2

CCNA Access List Sim 2

February 15th, 2014 Go to comments

Question

A network associate is adding security to the configuration of the Corp1 router. The user on host C should be able to use a web browser to access financial information from the Finance Web Server. No other hosts from the LAN nor the Core should be able to use a web browser to access this server. Since there are multiple resources for the corporation at this location including other resources on the Finance Web Server, all other traffic should be allowed.

The task is to create and apply a numbered access-list with no more than three statements that will allow ONLY host C web access to the Finance Web Server. No other hosts will have web access to the Finance Web Server. All other traffic is permitted.
Access to the router CLI can be gained by clicking on the appropriate host.

All passwords have been temporarily set to “cisco”.
The Core connection uses an IP address of 198.18.196.65
The computers in the Hosts LAN have been assigned addresses of 192.168.33.1 – 192.168.33.254
Host A 192.168.33.1
Host B 192.168.33.2
Host C 192.168.33.3
Host D 192.168.33.4
The servers in the Server LAN have been assigned addresses of 172.22.242.17 – 172.22.242.30
The Finance Web Server is assigned an IP address of 172.22.242.23.
The Public Web Server is assigned an IP address of 172.22.242.17

access_list_sim2.jpg

Answer and Explanation

(Note: If you are not sure how to use access-list, please check out my access-list tutorial at: http://www.9tut.com/access-list-tutorial, also some modifications about the access-list have been reported so you should read the “Some modifications” section at the end of this question to understand more. You can also download this sim to practice (open with Packet Tracer) here: http://www.9tut.com/download/9tut.com_Access-list_sim2.pkt

Corp1>enable (you may enter “cisco” as it passwords here)

We should create an access-list and apply it to the interface which is connected to the Server LAN because it can filter out traffic from both Sw-2 and Core networks. The Server LAN network has been assigned addresses of 172.22.242.17 – 172.22.242.30 so we can guess the interface connected to them has an IP address of 172.22.242.30 (.30 is the number shown in the figure). Use the “show running-config” command to check which interface has the IP address of 172.22.242.30.

Corp1#show running-config

access_list_sim_show_running.jpg

We learn that interface FastEthernet0/1 is the interface connected to Server LAN network. It is the interface we will apply our access-list (for outbound direction).

Corp1#configure terminal

Our access-list needs to allow host C – 192.168.33.3 to the Finance Web Server 172.22.242.23 via web (port 80)

Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80

Deny other hosts access to the Finance Web Server via web

Corp1(config)#access-list 100 deny tcp any host 172.22.242.23 eq 80

All other traffic is permitted

Corp1(config)#access-list 100 permit ip any any

Apply this access-list to Fa0/1 interface (outbound direction)

Corp1(config)#interface fa0/1
Corp1(config-if)#ip access-group 100 out

Notice: We have to apply the access-list to Fa0/1 interface (not Fa0/0 interface) so that the access-list can filter traffic coming from both the LAN and the Core networks. If we apply access list to the inbound interface we can only filter traffic from the LAN network.

In the real exam, just click on host C and open its web browser. In the address box type http://172.22.242.23 to check if you are allowed to access Finance Web Server or not. If your configuration is correct then you can access it.

Click on other hosts (A, B and D) and check to make sure you can’t access Finance Web Server from these hosts.

Finally, save the configuration

Corp1(config-if)#end
Corp1#copy running-config startup-config

(This configuration only prevents hosts from accessing Finance Web Server via web but if this server supports other traffic – like FTP, SMTP… then other hosts can access it, too.)

Notice: In the real exam, you might be asked to allow other host (A, B or D) to access the Finance Web Server so please read the requirement carefully.

Some modifications:

Modification 1:

permit host B from accessing finance server access-list 100 permit ip host 192.168.33.2 host 172.22.242.23
deny host B from accessing other servers (not the whole network) access-list 100 deny ip host 192.168.33.2 172.22.242.16 0.0.0.15
permit everything else access-list 100 permit ip any any

Modification 2:

Only allow Host C to to access the financial server access-list 100 permit ip host 192.168.33.3 host 172.22.242.23
Not allow anyone else in any way communicate with the financial server access-list 100 deny ip any host 172.22.242.23
Allow all other traffic access-list 100 permit ip any any

Modification 3:

- Host C should be able to use a web browser(HTTP)to access the Finance Web Server access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
- Other types of access from host C to the Finance Web Server should be blocked
- All access from hosts in the Core or local LAN to the Finance Web Server should be blocked
access-list 100 deny ip any host 172.22.242.23
(because the requirement says we can not use more than 3 statements so we have to use “any” here for the hosts in the Core and hosts in local LAN)
- All hosts in the Core and local LAN should be able to access the Public Web Server * access-list 100 permit ip any host
(If the question asks this, surely it has to give you the IP of Public Web Server) but in the exam you should use “access-list 100 permit ip any any”

Modification 4:

Host C should be able to use a web browser to access the financial web server access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
Other types of access from host C to the finance web server should be blocked access-list 100 deny ip host 192.168.33.3 host 172.22.242.23
All hosts in the core and on the local LAN should be able to access the Public web server * access-list 100 permit ip any host
(The IP of Public Web Server will surely be given in this question) but in the exam you should use “access-list 100 permit ip any any”

* There are some reports about the command of “All hosts in the core and on the local LAN should be able to access the Public web server” saying that the correct command should be “access-list 100 permit ip any any”, not “access-list 100 permit ip any host (IP of Public Web Server)”. Although I believe the second command is better but maybe you should use the first command “access-list 100 permit ip any any” instead as some reports said they got 100% when using this command (even if the question gives you the IP address of Public Web Server). It is a bug in this sim.

(Note: Don’t forget to apply this access list to the suitable interface or you will lose points
interface fa0/1
ip access-group 100 out

And in the exam, they may slightly change the requirements, for example host A, host B instead of host C… so make sure you read the requirement carefully and use the access-list correctly)

I created this sim in Packet Tracer v5.2.1 so you can practice with it. You will need new version of Packet Tracer to open it (v5.1+).

accesslist_sim2_packet_tracer.jpg

Download this sim here

Notice: After typing the commands above, if you make a “ping” from other hosts (PC0, PC1, PC3) then PC4 (Finance Web Server) can still reply because we just filter HTTP traffic, not ICMP traffic. To generate HTTP traffic, select “Web Browser” in the “Desktop” tab of these PCs. When a web browser opens, type the IP address of Finance Web Server and you can see how traffic flows in Simulation Mode.

accesslist2_test_http.jpg

And notice that in the initial configuration of this sim the Core network can ping Finance Web Server. We have to create an access-list that can filter this traffic too.

Other lab-sims on this site:

CCNA NAT SIM Question 1

CCNA NAT SIM Question 2

CCNA Frame Relay Sim

CCNA Configuration SIM Question (RIPv2 SIM)

CCNA VTP SIM

CCNA EIGRP LAB

CCNA Drag and Drop SIM

CCNA Implementation SIM

Comments
Comment pages
1 18 19 20 21 22 63 41
  1. Hein
    May 31st, 2013

    Passed today 856/1000, EIGRP,ACL2,VTP sims exact from 9tut.
    In EIGRP sim passive interface wan on serial, so I left it
    In exam, I don’t have much time left for acl2 sim & left it:’(
    Be sure not to spend so much time on early questions.
    I left 2 multiple choice & 1 sim(acl2) cuz I’m out of time.

    9 tut….. So helpful site

    Thanks ^_^

  2. Miss Soe
    May 31st, 2013

    Hein Congratulations!
    I passed CCNA 986/1000 yesterday too.
    EIGRP, ACL2, VTP sims same as 9tut.
    All are not so difficult. But u need to be sure u learned all such as vce questions,9tut very well bcuz not only for exam but also for building ur confidence.
    Ur confidence is vital before u go to exam room.If not,u may be so excited & panic.
    That’s just my experience & thought. fri
    Good Luck!! Everyone “Thanks a lot 9tut” U r vital for CCNA :)

  3. Anonymous
    May 31st, 2013

    Anyone have latest dumps taking 640-802 6-03-13 markvmorrow@gmail.com

  4. vickyz
    June 1st, 2013

    Hello friends,
    I have a query from my office requirement. NEED to install a test server on a system and run the web application with in my LAN network say ipaddress 10.108.122.25 255.255.255.0(system IP )
    THAT application has to accessed by some X user outside the network from different STATE.
    My boss asking me to provide an IP address to allow that X user to get access of this applicaiton for testing purpose.

    Please help me out with the query
    thank you all
    email:outlandish_05@yahoo.com

  5. shariq
    June 3rd, 2013

    Jns can you mail me pass for sure dumps
    shariq898@hotmail.com

  6. Anonymous
    June 3rd, 2013

    plan to take the CCNA 640 802 in July 2013. please could you guys forward the latest dumps… or were should i search help me……

  7. far
    June 3rd, 2013

    plan to take the CCNA 640 802 in July 2013. please could you guys forward the latest dumps… or were should search

  8. T_Dogg
    June 3rd, 2013

    Passed CCNA today, on my first try!

    Sims were VTP, EIGRP and Access-list 2.

    Big Thanks to 9tut.com! Gave me a great understanding of concepts that I missed in class and provided a very good understanding of what to expect in the exam.

  9. fofo
    June 5th, 2013

    i am taking the exam next week cant open this sim with Cisco packet tracer 5 what can i use to open it please help

  10. Akshay
    June 5th, 2013

    failed one time by 915 and nw preparing for 2nd time exam plz do help me send some profitable materials on my mail id. plz frnd its a humble request to all of u
    akkice@gmail.com

  11. Akshay
    June 5th, 2013

    failed one time by 815 and nw preparing for 2nd time exam plz do help me send some profitable materials on my mail id. plz frnd its a humble request to all of u
    akkice@gmail.com

  12. jose +254
    June 6th, 2013

    this sim was there in my exam on 2-june…..

    to my opinoin and exoerience…9tut is the best…..chek through al sims provided here and u wil get it right. i personally did within 2 and half weeks and made a pass with 894 marks

  13. happy
    June 6th, 2013

    I passed on my first try this sim was on my exam but with some modification and Ip changes, thanks 9tut they really help me to consolidate all the theory.

  14. Moderano
    June 8th, 2013

    hi does anybody has the latest dump for the ccna security ?

    and also does it exist a platform like 9tut for the ccna security ?

    thanks
    amoussoumoderand@yahoo.fr

  15. Anonymous
    June 8th, 2013

    i m taking the exam 640-802 on 24 june, plz give me some guidance about paper labs and tel me about new modifications in labs , and coman mistake, my email is umairanwarjpj@gmail.com

  16. praveen
    June 9th, 2013

    Host C should be able to use a web browser(HTTP)to access the Finance Web Server access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80
    - Other types of access from host C to the Finance Web Server should be blocked
    – All access from hosts in the Core or local LAN to the Finance Web Server should be blocked access-list 100 deny ip any host 172.22.242.23
    (because the requirement says we can not use more than 3 statements so we have to use “any” here for the hosts in the Core and hosts in local LAN)

    this was my question in yesterdays exam..but i just used access list 100 permit ip any any
    finally i got 45 % in this sim…i have a doubt with out giving last statement it well become implicit deny right..then y they reduced mark..author

  17. hussam
    June 9th, 2013

    i passed today with 947/1000 ,,,, thanks god
    3 sim question ( eigrp , acl2 , vtp )
    Jordan

  18. Anonymous
    June 9th, 2013

    praveen:

    have u put:

    int fa0/1
    ip access-group 100 out
    end
    copy running-config startup-config

    if not, then this is the reason why u only got 45%

  19. Robert
    June 11th, 2013

    raveen,

    I think Anonymous is right. You forgot to insert the access-list in fa0/1 interface.

  20. Yo
    June 11th, 2013

    Oscar and someone suggested applying the acl to fa0/0 IN.

    I haven’t seen all permutations of this, but based on the text presented by 9tut, this is NOT correct. If you place it as an IN on fa0/0 (leading to the switch with ABCD hosts) you fail to block CORE access to the finance web server which is a requirement.

  21. uzair
    June 11th, 2013

    15th june 2013 is my day

  22. JHON
    June 12th, 2013

    25 Jun 2013 is my day, acl should put Out direction and
    Remember ,

    copy running-config startup-config

  23. Mateo
    June 14th, 2013

    Hi friends!
    Could you please send me the last dump? I will have the exam at the end of this month.
    My address is yo_strike@yahoo.com
    Thank you in advance!

  24. Dominik
    June 14th, 2013

    My VTP lab was modification C with host A and different IPs.
    As I had 1000/1000 I can definitely confirm that the third line in ACL should be “access-list 100 permit ip any any”.

  25. Raj
    June 15th, 2013

    Hi friends,

    How to determine access lists numbers like 0 – 99 and 100 – 199.

    It would be greatly appreciated if any one could explain me.

    Thanks

  26. uzair
    June 15th, 2013

    i passed today by 973/1000 ….same simulations with different ip address :D very happy

  27. Mashaah-Nairobi Kenya
    June 16th, 2013

    Hi Raj n others
    Access contol lists 1-99 are refered to as standard while 100-199 as extended. Standard ACLs uses source ip address and wild card masks as the only parameters to define the statements. They are placed as close as possible to the destination since they dot include destination addresses.
    Extended ACLs uses parameters such as the source and destination ip address with their wild card masks, protocols (either tcp/udp) such as ftp, telnet, ssh, smtp, http, https etc and their port numbers e.g http=80, htps=443, ftp=20/21, telnet=23. They are place as close as possible to the source.
    After you define these statements, do not forget to apply the direction of the interface e.g interface fastethernet 0/1
    ip access-group 100 in/out
    op this will b of help
    Mashaa-Nairobi-Kenya

  28. anthony
    June 16th, 2013

    passed today 881/1000

    My sim was host B with HTTP access to the finance
    no one esle can access via HTTP to the finance
    all hosts need access to the public web server

    They provided the IP for the public web server.. use it!

  29. my
    June 17th, 2013

    Hello,

    When said no pass the core traffic, we have put:
    - interface f0/0
    access-group 100 out
    -interface s1/0
    access-group 100 out

    or we can type: interface f0/1
    access-group 100 in????

  30. mohamed
    June 17th, 2013

    im going tomorrow to take the ccna exam

  31. Alberto
    June 19th, 2013

    hi guys. Could someone explain the difference between the 3rd and the 4th modificicion modification of the access-list deny.
    A greeting. thanks

  32. bunny
    June 19th, 2013

    Hey guys i am giving the exam of ccna on 27th of june 13 ..could you guys please send me the latest dumps of that plzz
    bunnylubz4@gmail.com

  33. Theodros
    June 20th, 2013

    Thanks to http://www.9tut.com this is an awesome website. I passed CCNA exam because of you guys. Thanks

  34. pass4sure v10 653question
    June 22nd, 2013
  35. BB
    June 22nd, 2013

    passed my CCNA exam on the 16th June 2013. got the same question :)

  36. Apel
    June 23rd, 2013

    Friends i am giving the exam of ccna on 29th of june 13 ..could you guys please send me the latest dumps or vce file plzz plzz plzz…. my email id is apel_eu@yahoo.com

  37. Marem
    June 24th, 2013

    quick question i’ve wcaehtd a few videos on this and nobody mentions this if you host your own webpage this way do you have to keep your pc switched on 24/7 for it to be live on the net? in other words will people still be able to access my web page if my pc is off? if not then could i store these files etc on an external hdd and just keep that plugged to the net?sorry if this is a stupid question, i’m just now starting to learn )

  38. Mark
    June 24th, 2013

    can you help to explain this line in modification/first scenario pls.

    deny host B from accessing other servers (not the whole network) —

    access-list 100 deny ip host 192.168.33.2 172.22.242.16 0.0.0.15

    how did it come up with the target host 172.22.242.16 0.0.0.15
    i know that its a wildcard mask (0.0.0.15) but how bout the host ip address????

    TIA!

  39. andrew
    June 24th, 2013

    If there’s something with access i will use IP protocol in access-list statement, otherwise if there’s is access to webserver (host should use web-browser), i will define port 80 (web access), am i right ? :)

  40. andrew
    June 24th, 2013

    access-list 100 deny ip host 192.168.33.2 172.22.242.16 0.0.0.15
    U will block host B from acc. the whole network !!! That’s the second statement. Because if packet arrive on interface, destination finance server it would be permitted. If the dest. will be different, i will go on second statement and deny access.

    Maybe i was thinking about, there’s NOTT to deny access to whole network ! the fa0/1 port is in that network too. We have to use different mask to cover servers…. BUT on the hand, there’s no DNS server IP address in exhibit, so we have no options to know more about that. So U will use network 255.255.255.240 mask (show running-config on Router to see the mask of the interface).
    At the end, U will permit all other IP traffic.

  41. Nifo
    June 25th, 2013

    I passed my exam with a score of 894. I had that LAB, only the IP address changed and the host D was specified instead of host A. It was exactly the same questions.
    Big kiss to 9tut. u r the best.

  42. Aj
    June 25th, 2013

    920 – passed, thank you 9tut.

  43. Dhee
    June 26th, 2013

    Got this Sim in exam with Host C Http access to finance
    no one else can access finance and all hosts should have access to public web server
    So, dont panic and read the question very carefully….ATB!!

  44. Apel
    June 26th, 2013

    Can any one answer this question?

    Which of the following is a characteristic of full-duplex communication?
    A. It is a CSMA/CD network.
    B. It is a CSMA/CA network.
    C. It is point-to-point only.
    D. Hub communication is done via full duplex.

    please please please

  45. waqar ahmad
    June 27th, 2013

    i cleared my ccna on 26-6-2013. labs were acl 2, eigrp and vtp. however after configuring acl and applying it on my route interface, it was shown in running-config. but it never showed up in startup-config despite copying running-config to startup-config several times

  46. Nifo
    June 27th, 2013

    to Apel
    D

  47. rancho
    June 27th, 2013

    Please give me some exam questions may ask? Thank you all

  48. rancho
    June 27th, 2013

    wagar ahmad : What is your exam ? question that you did?

  49. Anonymous
    June 28th, 2013

    I just passed the exam with 986/1000. This dump 100% valid.

    Labs: EIGRP, VTP and ACL2

    ACL2,

    Host C 192.168.148.3
    Finance Web Server 172.22.162.17
    Public Web Server 172.22.162.18

    1. Allow Host C to access web on the Finance Web Server (access-list 100 permit tcp host 192.168.148.3 host 172.22.162.17 eq 80)
    2. Block Host C and other hosts to the Finance Web Server (access-list 100 deny ip any host 172.22.162.17)
    3. Allow all hosts to the Public Web Server (access-list 100 permit ip any host 172.22.162.18) ***

    *** You should use “access-list 100 permit ip any any” follow 9tut Lab instead, I lose 14 points with “access-list 100 permit ip any host 172.22.162.18″.

    Thank you! 9tut

  50. drxyy
    June 28th, 2013

    Please give me some exam questions may ask? Thank you all

Comment pages
1 18 19 20 21 22 63 41
  1. No trackbacks yet.
Add a Comment